Hovatek Forum
[Please help] Tecno A7 charging slowly and discharging when using - Printable Version

+- Hovatek Forum (https://forum.hovatek.com)
+-- Forum: MOBILE PHONES HELP SECTION (https://forum.hovatek.com/forum-75.html)
+--- Forum: Android (https://forum.hovatek.com/forum-76.html)
+--- Thread: [Please help] Tecno A7 charging slowly and discharging when using (/thread-15218.html)

Pages: 1 2


Tecno A7 charging slowly and discharging when using - donclark - 09-27-2016

Tecno A7 takes forever to charge. I have changed chargers, changed battery and even flashed stock ROM just to see if it will start charging fast but all to no avail. I am lost to what to do next.


RE: Tecno A7 charging slowly and discharging when using - [email protected] - 09-27-2016

(09-27-2016, 03:20 PM)donclark Wrote:  Tecno A7 takes forever to charge. I have changed chargers, changed battery and even flashed stock ROM just to see if it will start charging fast but all to no avail. I am lost to what to do next.
Bro, I'm also experiencing the same issue. . . its really annoying and sometimes, it doesn't even charge or it might even get stuck at 50something percent for what looks to me like ages and sometimes, it even discharges. I hope we find help.


RE: Tecno A7 charging slowly and discharging when using - X3non - 09-27-2016

(09-27-2016, 03:20 PM)donclark Wrote:  Tecno A7 takes forever to charge. I have changed chargers, changed battery and even flashed stock ROM just to see if it will start charging fast but all to no avail. I am lost to what to do next.
(09-27-2016, 03:20 PM)[email protected] Wrote:  Bro, I'm also experiencing the same issue. . . its really annoying and sometimes, it doesn't even charge or it might even get stuck at 50something percent for what looks to me like ages and sometimes, it even discharges. I hope we find help.

have you guys tried changing the USB charging port?


RE: Tecno A7 charging slowly and discharging when using - donclark - 09-27-2016

(09-27-2016, 11:03 PM)X3non Wrote:  
(09-27-2016, 03:20 PM)donclark Wrote:  Tecno A7 takes forever to charge. I have changed chargers, changed battery and even flashed stock ROM just to see if it will start charging fast but all to no avail. I am lost to what to do next.
(09-27-2016, 03:20 PM)[email protected] Wrote:  Bro, I'm also experiencing the same issue. . . its really annoying and sometimes, it doesn't even charge or it might even get stuck at 50something percent for what looks to me like ages and sometimes, it even discharges. I hope we find help.

have you guys tried changing the USB charging port?

How would you change a charging port that works very well and is seen perfectly by a laptop?


RE: Tecno A7 charging slowly and discharging when using - [email protected] - 09-28-2016

I just found out my device shows charging over USB while it is plugged into an ac power supply... Before this trauma started, my device charges slowly when I connect it to a PC over USB but charges fast when connected to an ac outlet. Why does it show charging over USB when it is not connected via USB?


RE: Tecno A7 charging slowly and discharging when using - hovatek - 09-28-2016

(09-27-2016, 03:20 PM)donclark Wrote:  Tecno A7 takes forever to charge. I have changed chargers, changed battery and even flashed stock ROM just to see if it will start charging fast but all to no avail. I am lost to what to do next.

Have you tried changing the charging port?


RE: Tecno A7 charging slowly and discharging when using - donclark - 09-28-2016

(09-28-2016, 09:43 AM)hovatek Wrote:  
(09-27-2016, 03:20 PM)donclark Wrote:  Tecno A7 takes forever to charge. I have changed chargers, changed battery and even flashed stock ROM just to see if it will start charging fast but all to no avail. I am lost to what to do next.

Have you tried changing the charging port?

If the charging port is bad, why do my laptop see it? I mean I used my laptop to flash a stock ROM just yesterday to find out if it were a ROM problem.


RE: Tecno A7 charging slowly and discharging when using - [email protected] - 09-28-2016

(09-28-2016, 09:43 AM)hovatek Wrote:  
(09-27-2016, 03:20 PM)donclark Wrote:  Tecno A7 takes forever to charge. I have changed chargers, changed battery and even flashed stock ROM just to see if it will start charging fast but all to no avail. I am lost to what to do next.

Have you tried changing the charging port?
I changed the port once. . . it worked for a while and has stopped again in the space of a month.


RE: Tecno A7 charging slowly and discharging when using - X3non - 09-28-2016

(09-28-2016, 09:58 AM)donclark Wrote:  If the charging port is bad, why do my laptop see it? I mean I used my laptop to flash a stock ROM just yesterday to find out if it were a ROM problem.

a faulty charging port can cause slow charging as well as battery percent reducing even when charging
seeing as you've tried every other option including flashing stock rom and the problem still persist,
then you should consider replacing the USB port (with a new one)


RE: Tecno A7 charging slowly and discharging when using - donclark - 09-28-2016

(09-28-2016, 05:11 PM)X3non Wrote:  
(09-28-2016, 09:58 AM)donclark Wrote:  If the charging port is bad, why do my laptop see it? I mean I used my laptop to flash a stock ROM just yesterday to find out if it were a ROM problem.

a faulty charging port can cause slow charging as well as battery percent reducing even when charging
seeing as you've tried every other option including flashing stock rom and the problem still persist,
then you should consider replacing the USB port (with a new one)

Well I took it to a repairer today and he confirmed there's nothing wrong with the charging port...