Hovatek Forum
[Please help] Magnus SX5QC Hard Buttons Mixed Up (MT6582) - Printable Version

+- Hovatek Forum (https://forum.hovatek.com)
+-- Forum: MOBILE PHONES HELP SECTION (https://forum.hovatek.com/forum-75.html)
+--- Forum: Android (https://forum.hovatek.com/forum-76.html)
+--- Thread: [Please help] Magnus SX5QC Hard Buttons Mixed Up (MT6582) (/thread-21349.html)



Magnus SX5QC Hard Buttons Mixed Up (MT6582) - ColinB - 12-12-2017

Good morning Forum.

This is my first venture into the world of Android Phone, 3 weeks now and I'm really enjoying it so far.

I have somewhat obscure Chinese phone I got 2 years ago from "Mad-Bid" for £50, that is labeled up as.. NTech (--w.ntech.pt). It is a 1GB/8GB Android 4.2.2 model.

Hardware : MT6582
Model : Magnus_SX5QC
Build number : ALPS.JB5.MP.V1.5
Build date UTC : 20141008-020417
Android  v : 4.2.2
Baseband v: TL.MOLY.WR8.W1315.MD.WG.MP.V10.P2, 2013/12/26 10:11
Kernel v : 3.4.5 ([email protected]) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP  Wed Oct 8 09:59:47 CST 2014


I never used the phone as the speaker volume was rubbish, so so it went in the drawer till now, when I decided to use it as practice before messing around with my new tablet.

After reading/watching a web tutorial/video "How to unlock/root any Chinese phone" (not the proper Hovatek [Tutorial] which I found later on, and this forum), I proceeded to do just that. So cut a long story short, my battery didn't have enough power so things didn't go according to plan.

But last week I got it sort of  working and now I am quite happy flashing rooting it etc with MKDroid & SPFlash tools. It not without its problems though, the main 2 being the Hard Buttons & Reboot from recovery or app.

Hard Button Problem

Start normal doesn't work and requires hold Vol- then press Power. (I think that should be download mode).

Hold Vol+ before connecting USB for META doesn't work, as does META for any connection to MAUI META etc. IMEI, WiFi S/N etc changes.

Start Recover works normal hold Vol+ then Power. But reboot from CWM stops at a blank screen. It can be continued by holding Vol-, Vol+ seems to take you into "Safe Mode" although I cant be quite sure as both seem to depend on how long or often you press/hold the button(s).

Physically the buttons work normal after full boot. Volume & Lock are normal.

In non-root recovery (Vol+ & Pwr) the Vol +/- move up down the menu and the Pwr selects normally. In rooted "CWM" Vol- moves down the menu and Vol+ selects. Also the screen is upside down.

Soft Reboot 

Using a boot manager app (rooted) full reboot shuts down then just hangs. The other features on the app seem to work OK.

As mentioned rebooting out of recovery does the same.

My first thought are that during my initial messing around I've managed to code the buttons wrong (if that's possible).


On final thing to add to the story is although I've been unable to source a Manufacturers ROM, I eventually got hold of a version from a site in India, I cant remember what site but its available If anyone needs it.

Hopefully attached should be the scatters of both.

Thanks in advance


RE: Magnus SX5QC Hard Buttons Mixed Up (MT6582) - ColinB - 12-12-2017

I have managed to get Maui META to connect by

Power OFF the phone. Hold Vol- then connect USB and release Vol- Phone stays at boot logo and I get connected.

Unfortunately I cant find the DB file on my phone, there is only 1 file


RE: Magnus SX5QC Hard Buttons Mixed Up (MT6582) - hovatek - 12-12-2017

(12-12-2017, 03:31 PM)ColinB Wrote:  I have managed to get Maui META to connect by

Power OFF the phone. Hold Vol- then connect USB and release Vol- Phone stays at boot logo and I get connected.

Unfortunately I cant find the DB file on my phone, there is only 1 file

First off, I don't think you damaged anything, causing this anomaly in buttons. It does happen especially on older MTK phones and SPD phones.
As for Maui Meta, what exactly are you trying to do, write IMEI? If that's the case then see other methods at https://forum.hovatek.com/thread-116.html


RE: Magnus SX5QC Hard Buttons Mixed Up (MT6582) - ColinB - 12-12-2017

Hi Hovatec,

thanks for the quick reply. IMEI is good with Engineer mode.

System problems I'm having are:

I can connect to my WiFi LAN and ftp, but cant get on the web. And of course random MAC address on the WiFi.


RE: Magnus SX5QC Hard Buttons Mixed Up (MT6582) - hovatek - 12-13-2017

(12-12-2017, 08:24 PM)ColinB Wrote:  Hi Hovatec,

thanks for the quick reply. IMEI is good with Engineer mode.

System problems I'm having are:

I can connect to my WiFi LAN and ftp, but cant get on the web. And of course random MAC address on the WiFi.

1. Are you able to surf via mobile data
2. Have you tried a different WiFi source?


RE: Magnus SX5QC Hard Buttons Mixed Up (MT6582) - ColinB - 12-14-2017

(12-13-2017, 02:56 PM)hovatek Wrote:  
(12-12-2017, 08:24 PM)ColinB Wrote:  Hi Hovatec,

thanks for the quick reply. IMEI is good with Engineer mode.

System problems I'm having are:

I can connect to my WiFi LAN and ftp, but cant get on the web. And of course random MAC address on the WiFi.

1. Are you able to surf via mobile data
2. Have you tried a different WiFi

Sorry for the late reply (I thought I had instant notification by email turned on).

I sorted the WiFi problem. Turned out it was a "Known Fault" with my ISP router. It has 2 guest WiFi accounts on the box and the one I chose was the bad one.

Not sure if you want I should start another thread about the other issues I have created with the phone, but seeing as there are not many English threads out there for the Magnus SX5QC, it would be good if I could stick with this one.

In no particular order:

No Battery-Charge Animation
Mixed Up Hard Buttons.
Soft Reboot

Many thanks


RE: Magnus SX5QC Hard Buttons Mixed Up (MT6582) - hovatek - 12-14-2017

(12-14-2017, 08:49 AM)ColinB Wrote:  Sorry for the late reply (I thought I had instant notification by email turned on).

I sorted the WiFi problem. Turned out it was a "Known Fault" with my ISP router. It has 2 guest WiFi accounts on the box and the one I chose was the bad one.

Not sure if you want I should start another thread about the other issues I have created with the phone, but seeing as there are not many English threads out there for the Magnus SX5QC, it would be good if I could stick with this one.

In no particular order:

No Battery-Charge Animation
Mixed Up Hard Buttons.
Soft Reboot

Many thanks

New thread please


RE: Magnus SX5QC Hard Buttons Mixed Up (MT6582) - ColinB - 12-14-2017

OK no problem, but if you could point me in the the direction of how to flash back ROM_0 created in SPFlashTool using SPFlashTool as I cant find it anywhere. I've been through the advanced settings in SPFlashTool and I'm a bit lost.

Thanks Colin


RE: Magnus SX5QC Hard Buttons Mixed Up (MT6582) - X3non - 12-15-2017

(12-14-2017, 01:19 PM)ColinB Wrote:  OK no problem, but if you could point me in the the direction of how to flash back ROM_0 created in SPFlashTool using SPFlashTool as I cant find it anywhere. I've been through the advanced settings in SPFlashTool and I'm a bit lost.

Thanks Colin

if you dumped the entire rom of your device using SPft, then you need to process the ROM file using MTKdroidtool in order to get an SP flash tool flashable rom.
* read from step 15 in the guide @ https://forum.hovatek.com/thread-526.html