Hovatek Forum
[Please help] Bricked Tecno K7 - Printable Version

+- Hovatek Forum (https://forum.hovatek.com)
+-- Forum: MOBILE PHONES HELP SECTION (https://forum.hovatek.com/forum-75.html)
+--- Forum: Android (https://forum.hovatek.com/forum-76.html)
+--- Thread: [Please help] Bricked Tecno K7 (/thread-23114.html)

Pages: 1 2


Bricked Tecno K7 - Degereji - 06-11-2018

My brothers tecno K7 stopped displaying images and also the charging screen after it suddenly shuts down while he was watching movie....so it became blank but he can receive calls just that it stopped showing images so he now formatted and flashed the complete Tecno K7 rom found on this site and now the phone doesn’t even power on or respond to wall socket..but it connects to sp flash when connected and left for a while.....he flashed the rom when the phone has low battery.....


RE: Bricked Tecno K7 - phonesurgeon - 06-11-2018

Charge the battery for as long as you can.
NB: Do not ever flash(or perform such operations) on a phone on low battery, one of the results is what you are facing.
It could take a day before the phone powers on so leave it on charge (wall socket).

Did you encounter any error when flashing?

Sent from my GT-N7100 using Tapatalk


RE: Bricked Tecno K7 - Degereji - 06-11-2018

(06-11-2018, 05:04 AM)paafugees Wrote:  Charge the battery for as long as you can.
NB: Do not ever flash(or perform such operations) on a phone on low battery, one of the results is what you are facing.
It could take a day before the phone powers on so leave it on charge (wall socket).

Did you encounter any error when flashing?

Sent from my GT-N7100 using Tapatalk

No I didn’t experience any errors at all


RE: Bricked Tecno K7 - hovatek - 06-11-2018

(06-11-2018, 08:46 AM)Degereji Wrote:  No I didn’t experience any errors at all

Either the battery is drained or you flashed the firmware for the wrong build number.
Keep charging so you can rule out drained battery.if you can, take out and re-insert the battery.


RE: Bricked Tecno K7 - Degereji - 06-11-2018

(06-11-2018, 01:23 PM)hovatek Wrote:  
(06-11-2018, 08:46 AM)Degereji Wrote:  No I didn’t experience any errors at all

Either the battery is drained or you flashed the firmware for the wrong build number.
Keep charging so you can rule out drained battery.if you can, take out and re-insert the battery.

Yh I can disconnect the battery clip but does it involve any extra procedures after taking it out....as in what do I do next?


RE: Bricked Tecno K7 - Degereji - 06-11-2018

(06-11-2018, 01:23 PM)hovatek Wrote:  
(06-11-2018, 08:46 AM)Degereji Wrote:  No I didn’t experience any errors at all

Either the battery is drained or you flashed the firmware for the wrong build number.
Keep charging so you can rule out drained battery.if you can, take out and re-insert the battery.


Couldn’t find the attach image button I would’ve attached the Image of the back I opened it....this is whats written
H8019_MAIN_PCB_V1.2
Its the 1GB RAM model
So help me specify exactly which OS to flash from this link
https://forum.hovatek.com/thread-20510.html
Downloaded the first OS complete already


RE: Bricked Tecno K7 - X3non - 06-11-2018

(06-11-2018, 06:52 PM)Degereji Wrote:  Couldn’t find the attach image button I would’ve attached the Image of the back I opened it....this is whats written  
H8019_MAIN_PCB_V1.2
Its the 1GB RAM model
So help me specify exactly which OS to flash from this link
https://forum.hovatek.com/thread-20510.html
Downloaded the first OS complete already

sadly thats not full build number and no way of telling what the original build number except either you or your brother remembers what it was
you'll have to try flashing the different rom builds from that thread [skipping the one you already flashed] and hope one of them matches yours


RE: Bricked Tecno K7 - Degereji - 06-11-2018

(06-11-2018, 08:31 PM)X3non Wrote:  
(06-11-2018, 06:52 PM)Degereji Wrote:  Couldn’t find the attach image button I would’ve attached the Image of the back I opened it....this is whats written  
H8019_MAIN_PCB_V1.2
Its the 1GB RAM model
So help me specify exactly which OS to flash from this link
https://forum.hovatek.com/thread-20510.html
Downloaded the first OS complete already

sadly thats not full build number and no way of telling what the original build number except either you or your brother remembers what it was
you'll have to try flashing the different rom builds from that thread [skipping the one you already flashed] and hope one of them matches yours

Checked it from another k7 with same specs as this oneexperiencing the problem an it happens to match the first OS I downloaded......after the flashing it didn’t power on but vibrates like it’ll turn on when I press the power button......the only thing I am certain about here is that it had a very low battery


RE: Bricked Tecno K7 - innagee - 06-12-2018

(06-11-2018, 08:41 PM)Degereji Wrote:  
(06-11-2018, 08:31 PM)X3non Wrote:  
(06-11-2018, 06:52 PM)Degereji Wrote:  Couldn’t find the attach image button I would’ve attached the Image of the back I opened it....this is whats written  
H8019_MAIN_PCB_V1.2
Its the 1GB RAM model
So help me specify exactly which OS to flash from this link
https://forum.hovatek.com/thread-20510.html
Downloaded the first OS complete already

sadly thats not full build number and no way of telling what the original build number except either you or your brother remembers what it was
you'll have to try flashing the different rom builds from that thread [skipping the one you already flashed] and hope one of them matches yours

Checked it from another k7 with same specs as this oneexperiencing the problem an it happens to match the first OS I downloaded......after the flashing it didn’t power on but vibrates like it’ll turn on when I press the power button......the only thing I am certain about here is that it had a very low battery

keep charging the battery or try a different battery.


RE: Bricked Tecno K7 - hovatek - 06-13-2018

(06-11-2018, 08:41 PM)Degereji Wrote:  Checked it from another k7 with same specs as this oneexperiencing the problem an it happens to match the first OS I downloaded......after the flashing it didn’t power on but vibrates like it’ll turn on when I press the power button......the only thing I am certain about here is that it had a very low battery

So far the working phone is a K7, its bound to have similar specs. This doesn't mean they're of the same build number.
If constant charging (after removing and re-inserting the battery) hasn't helped then download and flash another firmware