Hovatek Forum
SOLVED!!!---TWRP Porter works ok but white screen after flashing ported recovery - Printable Version

+- Hovatek Forum (https://forum.hovatek.com)
+-- Forum: DEVELOPMENT (https://forum.hovatek.com/forum-38.html)
+--- Forum: Android (https://forum.hovatek.com/forum-39.html)
+--- Thread: SOLVED!!!---TWRP Porter works ok but white screen after flashing ported recovery (/thread-26504.html)

Pages: 1 2


SOLVED!!!---TWRP Porter works ok but white screen after flashing ported recovery - Alexanderlll - 01-22-2019

weird, always work, but not this time in nougat sc9832a, flashed and a white screen appears and then, reboots to system, i tried to manually port with Android Image Studio but an error shows something like offset and other related partition stuff, the recovery is a RAW backup image with 20mb, ive always port recoveries with the porter tool but always are .pac extracted images, not RAW full backup, the extracted .pac recoveries always be 14mb, 15mb and so on, not a full RAW image filled the hole partition, i tried to extract recovery.img with root but always gave me a full 20mb RAW img, how can i extract just 14mb/15mb/16mb recovery.img? i think the size are the problem or the image type, i appreciated all your help, i really need a TWRP for restore build.prop and other files if i mess it up, thanks a lot!


TWRP porter works ok but white screen after flash - Alexanderlll - 01-22-2019

weird, always work, but not this time in nougat sc9832a, flashed and a white screen appears and then, reboots to system, i tried to manually port with Android Image Studio but an error shows something like offset and other related partition stuff, the recovery is a RAW backup image with 20mb, ive always port recoveries with the porter tool but always are .pac extracted images, not RAW full backup, the extracted .pac recoveries always be 14mb, 15mb and so on, not a full RAW image filled the hole partition, i tried to extract recovery.img with root but always gave me a full 20mb RAW img, how can i extract just 14mb/15mb/16mb recovery.img? i think the size are the problem or the image type, i appreciated all your help, i really need a TWRP for restore build.prop and other files if i mess it up, thanks a lot!


RE: TWRP Porter works ok but white screen after flashing ported recovery - X3non - 01-22-2019

(01-22-2019, 12:14 AM)Alexanderlll Wrote:  weird, always work, but not this time in nougat sc9832a, flashed and a white screen appears and then, reboots to system, i tried to manually port with Android Image Studio but an error shows something like offset and other related partition stuff, the recovery is a RAW backup image with 20mb, ive always port recoveries with the porter tool but always are .pac extracted images, not RAW full backup, the extracted .pac recoveries always be 14mb, 15mb and so on, not a full RAW image filled the hole partition, i tried to extract recovery.img with root but always gave me a full 20mb RAW img, how can i extract just 14mb/15mb/16mb recovery.img? i think the size are the problem or the image type, i appreciated all your help, i really need a TWRP for restore build.prop and other files if i mess it up, thanks a lot!

whether its raw or not shouldn't be a problem. flash back your stock recovery dump lets know if you're able to boot into recovery mode
BTW how did you flash the custom recovery?


RE: TWRP Porter works ok but white screen after flashing ported recovery - Alexanderlll - 01-23-2019

the recovery dump RAW .img are fine, flash ok in fastboot and booted ok, flash ok with root and rashr, booting in recovery normally and everything works, and the TWRP Porter says porting ok and you need to patch VM-verity but i have root with patched Magisk boot.img, the phone boots ok even with the bad-ported recovery flashed


RE: TWRP Porter works ok but white screen after flashing ported recovery - X3non - 01-23-2019

(01-23-2019, 12:44 AM)Alexanderlll Wrote:  the recovery dump RAW .img are fine, flash ok in fastboot and booted ok, flash ok with root and rashr, booting in recovery normally and everything works, and the TWRP Porter says porting ok and you need to patch VM-verity but i have root with patched Magisk boot.img, the phone boots ok even with the bad-ported recovery flashed

ok, just needed to verify that stock recovery dump is in order
try porting using version 5 & 6 in the tool, lets know if any of them works


RE: TWRP Porter works ok but white screen after flashing ported recovery - Alexanderlll - 01-24-2019

X3non says:

ok, just needed to verify that stock recovery dump is in order
try porting using version 5 & 6 in the tool, lets know if any of them works

JAJAJAJA it works!!! Amazing!!!, and everything works, what the heeeell, Thank You so much buddy, and Thanks to all the Hovatek Team, finally i got my TWRP ready to flash without pc backup and lets go to mod and debloat Big Grin


RE: SOLVED!!!---TWRP Porter works ok but white screen after flashing ported recovery - Alexanderlll - 01-24-2019

My system is Android 7.0, works porting with Android 6 option


RE: SOLVED!!!---TWRP Porter works ok but white screen after flashing ported recovery - shankar1790 - 01-24-2019

(01-24-2019, 08:16 AM)Alexanderlll Wrote:  My system is Android 7.0, works porting with Android 6 option

Which tool version you had used for porting recovery  (auto tool) stable or beta.


RE: TWRP Porter works ok but white screen after flashing ported recovery - shankar1790 - 01-24-2019

(01-24-2019, 06:19 AM)Alexanderlll Wrote:  X3non says:

ok, just needed to verify that stock recovery dump is in order
try porting using version 5 & 6 in the tool, lets know if any of them works

JAJAJAJA it works!!! Amazing!!!, and everything works, what the heeeell, Thank You so much buddy, and Thanks to all the Hovatek Team, finally i got my TWRP ready to flash without pc backup and lets go to mod and debloat Big Grin
Is it booted successfully ???
No white screen and reboot


RE: TWRP Porter works ok but white screen after flashing ported recovery - Alexanderlll - 01-25-2019

(01-24-2019, 08:53 AM)shankar1790 Wrote:  
(01-24-2019, 06:19 AM)Alexanderlll Wrote:  X3non says:

ok, just needed to verify that stock recovery dump is in order
try porting using version 5 & 6 in the tool, lets know if any of them works

JAJAJAJA it works!!! Amazing!!!, and everything works, what the heeeell, Thank You so much buddy, and Thanks to all the Hovatek Team, finally i got my TWRP ready to flash without pc backup and lets go to mod and debloat Big Grin
Is it booted successfully ???
No white screen and reboot

Succeed, boots ok in system and recovery works, mount partitions, backups, everything Big Grin