Hovatek Forum
[Please help] How to remove a virus from Leagoo Kiicaa software - Printable Version

+- Hovatek Forum (https://forum.hovatek.com)
+-- Forum: DEVELOPMENT (https://forum.hovatek.com/forum-38.html)
+--- Forum: Android (https://forum.hovatek.com/forum-39.html)
+--- Thread: [Please help] How to remove a virus from Leagoo Kiicaa software (/thread-26572.html)



How to remove a virus from Leagoo Kiicaa software - ryfoz - 28-01-2019

I'm helping someone with an issue with his Leagoo Kiicaa

He claims the phone was working well one evening and by the next day it started force-stopping and crashing apps by itself

He said he then tried factory reset, which normally should show an android bot and the wiping animation together but it just wrote and executed the command without showing the bot...long story short...the wipe brought him back to the same state the device was b4 it was wiped: security and all that


Now since I have collected the device as well I have tried the wipe myself, enabled debugging..tried to flash a new firmaware compatible with it (t592) and surprisingly it kept coming back to the same state...I even tried uninstalling some apps...but after some reboot it comes back to it AGAIN


I even wiped the whole partition and switched it on without having flashed anything into it and guess what it boots and comes up normally again and as it was (but I get OK confirmation from SPFT)
one thing that didn't work is fastboot oem unlock

And the oem unlock toggle in developer options keeps bouncing back to off


How do I solve this pls?  I never believed a virus attack b4 until now


RE: How to remove a virus from Leagoo Kiicaa software - X3non - 28-01-2019

(28-01-2019, 02:39 AM)ryfoz Wrote:  I'm helping someone with an issue with his Leagoo Kiicaa
...
How do I solve this pls?  I never believed a virus attack b4 until now

this is hardware problem -- 'faulty emmc chip' and requires replacement


RE: How to remove a virus from Leagoo Kiicaa software - ryfoz - 28-01-2019

(28-01-2019, 11:09 AM)X3non Wrote:  this is hardware problem -- 'faulty emmc chip' and requires replacement

Hmmmm...okay and thank you so much sir


RE: How to remove a virus from Leagoo Kiicaa software - shankar1790 - 29-01-2019

I have no experience with mtk but i had similar situation before with my sc7731 my system cache and data failed to mount in recovery.
When i flashed its stock rom the rom is successfully flashed every time but situation is same.
What i did to partition my external sd card (16gb) to size of internal partions like system, cache,data,external sd and pached my boot img to change the mount point of system,data,cache,and external sd to memory card and flashed my stockrom .zip(i created) in twrp recovery and finally i am able to use my device
And yes the problem was bad/currupted emmc (mine was kingston brand)