Mediatek Auto TWRP Recovery Porter V1.4 by Team Hovatek not working for me - Printable Version

+- Hovatek Forum (https://forum.hovatek.com)
+-- Forum: DEVELOPMENT (https://forum.hovatek.com/forum-38.html)
+--- Forum: Android (https://forum.hovatek.com/forum-39.html)
+--- Thread: Mediatek Auto TWRP Recovery Porter V1.4 by Team Hovatek not working for me (/thread-29072.html)



Mediatek Auto TWRP Recovery Porter V1.4 by Team Hovatek not working for me - rbk - 07-29-2019

I've used this before with success on the same device I'm using right now. We recently received a software upgrade and for some reason it will not work. 
I need to root this device but I cannot do this by unlocking the bootloader as the device does not have volume keys. I managed to root it previously by flashing over the custom TWRP recovery with SP Flash tool and then adb reboot recovery. However since the software upgrade when I boot to the recovery image I get the native android recovery and not my custom TWRP. 
Please help.

I'm trying to attach my recovery images without success I keep getting an error.


Mediatek Auto TWRP Recovery Porter V1.4 by Team Hovatek not working for me - innagee - 07-30-2019

(07-29-2019, 08:46 PM)rbk Wrote:  I've used this before with success on the same device I'm using right now. We recently received a software upgrade and for some reason it will not work. 
I need to root this device but I cannot do this by unlocking the bootloader as the device does not have volume keys. I managed to root it previously by flashing over the custom TWRP recovery with SP Flash tool and then adb reboot recovery. However since the software upgrade when I boot to the recovery image I get the native android recovery and not my custom TWRP. 
Please help.

I'm trying to attach my recovery images without success I keep getting an error.

What’s the phone’s model/chipset ?
Have you tried tried rooting using the guide @ https://forum.hovatek.com/thread-21427.html ?


RE: Mediatek Auto TWRP Recovery Porter V1.4 by Team Hovatek not working for me - rbk - 07-30-2019

(07-30-2019, 07:15 AM)innagee Wrote:  
(07-29-2019, 08:46 PM)rbk Wrote:  I've used this before with success on the same device I'm using right now. We recently received a software upgrade and for some reason it will not work. 
I need to root this device but I cannot do this by unlocking the bootloader as the device does not have volume keys. I managed to root it previously by flashing over the custom TWRP recovery with SP Flash tool and then adb reboot recovery. However since the software upgrade when I boot to the recovery image I get the native android recovery and not my custom TWRP. 
Please help.

I'm trying to attach my recovery images without success I keep getting an error.

What’s the phone’s model/chipset ?
Have you tried tried rooting using the guide @ https://forum.hovatek.com/thread-21427.html ?
Mediatek MT6737M running 6.0 Marshmallow I've tried a generic TWRP for MT6737M with the same results. I'm trying to attach the original recovery image but I keep getting an error that the upload is empty.


RE: Mediatek Auto TWRP Recovery Porter V1.4 by Team Hovatek not working for me - rbk - 07-30-2019

(07-30-2019, 01:57 PM)rbk Wrote:  
(07-30-2019, 07:15 AM)innagee Wrote:  
(07-29-2019, 08:46 PM)rbk Wrote:  I've used this before with success on the same device I'm using right now. We recently received a software upgrade and for some reason it will not work. 
I need to root this device but I cannot do this by unlocking the bootloader as the device does not have volume keys. I managed to root it previously by flashing over the custom TWRP recovery with SP Flash tool and then adb reboot recovery. However since the software upgrade when I boot to the recovery image I get the native android recovery and not my custom TWRP. 
Please help.

I'm trying to attach my recovery images without success I keep getting an error.

What’s the phone’s model/chipset ?
Have you tried tried rooting using the guide @ https://forum.hovatek.com/thread-21427.html ?
Mediatek MT6737M running 6.0 Marshmallow I've tried a generic TWRP for MT6737M with the same results. I'm trying to attach the original recovery image but I keep getting an error that the upload is empty.
I'd done that method before (https://forum.hovatek.com/thread-21427.html) it resulted in serious operational issues. I can't and don't want to touch the boot and I need to root with SuperSU not Magisk.


RE: Mediatek Auto TWRP Recovery Porter V1.4 by Team Hovatek not working for me - rbk - 07-30-2019

(07-30-2019, 02:03 PM)rbk Wrote:  
(07-30-2019, 01:57 PM)rbk Wrote:  
(07-30-2019, 07:15 AM)innagee Wrote:  
(07-29-2019, 08:46 PM)rbk Wrote:  I've used this before with success on the same device I'm using right now. We recently received a software upgrade and for some reason it will not work. 
I need to root this device but I cannot do this by unlocking the bootloader as the device does not have volume keys. I managed to root it previously by flashing over the custom TWRP recovery with SP Flash tool and then adb reboot recovery. However since the software upgrade when I boot to the recovery image I get the native android recovery and not my custom TWRP. 
Please help.

I'm trying to attach my recovery images without success I keep getting an error.

What’s the phone’s model/chipset ?
Have you tried tried rooting using the guide @ https://forum.hovatek.com/thread-21427.html ?
Mediatek MT6737M running 6.0 Marshmallow I've tried a generic TWRP for MT6737M with the same results. I'm trying to attach the original recovery image but I keep getting an error that the upload is empty.
I'd done that method before (https://forum.hovatek.com/thread-21427.html) it resulted in serious operational issues. I can't and don't want to touch the boot and I need to root with SuperSU not Magisk.
Okay I've managed figure out that the issue I'm having is related to this file in my system folder: recovery-from-boot.p. It's essentially overwriting my custom recovery every time I boot up. To fix this I just need to boot to recovery while powered down. I can't do that without volume buttons. I can also change the name of the file or delete the file but I can't accomplish that without root.

I'm going to attempt to root with Magisk and the link you sent me. Delete that file. Then flash over the original boot image (essentially not touching it) and try to boot the my twrp again.


RE: Mediatek Auto TWRP Recovery Porter V1.4 by Team Hovatek not working for me - X3non - 07-30-2019

(07-30-2019, 03:47 PM)rbk Wrote:  ...
I'm going to attempt to root with Magisk and the link you sent me. Delete that file. Then flash over the original boot image (essentially not touching it) and try to boot the my twrp again.

good idea! you can try this


RE: Mediatek Auto TWRP Recovery Porter V1.4 by Team Hovatek not working for me - rbk - 09-25-2019

(07-30-2019, 04:53 PM)X3non Wrote:  
(07-30-2019, 03:47 PM)rbk Wrote:  ...
I'm going to attempt to root with Magisk and the link you sent me. Delete that file. Then flash over the original boot image (essentially not touching it) and try to boot the my twrp again.

good idea! you can try this
Just to close this thread for anyone having the same problem rooting the boot with magisk and then using that to modify the "recovery-from-boot.p" file was successful. Here's my procedure:

1. Pulled a copy of the boot image from the device to the device sdcard:
Code:
adb shell dd if=/dev/block/[boot location] of=/sdcard/boot.img

2. Pushed over Magisk

3. Modified boot.img with Magisk and pulled it on my PC

4. Turned off device and flashed over just the boot.img and my TWRP recovery.img

5. Restarted the device and changed the name of "recovery-from-boot.p" to "recovery-from-boot.bak"
Code:
adb shell mv system/recovery-from-boot.p system/recovery-from-boot.bak
The name change is important. Usually just launching the TWRP should change the name of that file but for some reason that wasn't happening. 

6. Push over SuperSU zip file and 
Code:
adb reboot recovery


Once you use your TWRP To install SuperSU and restart, uninstall Magisk and you're now rooted with SuperSU!