Hovatek Forum
Blackview BV9600 pro Rooting - Printable Version

+- Hovatek Forum (https://forum.hovatek.com)
+-- Forum: DEVELOPMENT (https://forum.hovatek.com/forum-38.html)
+--- Forum: Android (https://forum.hovatek.com/forum-39.html)
+--- Thread: Blackview BV9600 pro Rooting (/thread-38418.html)

Pages: 1 2 3


Blackview BV9600 pro Rooting - gabstar - 19-03-2021

Please I need help, trying to root and own my Blackview BV9600 pro, using fastboot, after unlocking and flashing on the device the custom recovery stil on the cmd fastboot I booted to the recovery but my device showed

Orange State
Your devices has been unlocked and can't be trusted
Your devices will boot in 5 seconds

Again I tried flash recovery, but fastboot devices refuse to identify my device and when I tried WwR MTK (2.51 version) it saw the phone but showed

Device is in sleep mode
Need to wake it up!!!

Meanwhile my phone is on with me and not asleep

PLEASE WHAT CANI DO T FIX THIS?


RE: Blackview BV9600 pro Rooting - X3non - 19-03-2021

(19-03-2021, 04:36 PM)gabstar Wrote:  Please I need help, trying to root and own my Blackview BV9600 pro, using fastboot, after unlocking and flashing on the device the custom recovery stil on the cmd fastboot I booted to the recovery but my device showed

Orange State
Your devices has been unlocked and can't be trusted
Your devices will boot in 5 seconds

Again I tried flash recovery, but fastboot devices refuse to identify my device and when I tried WwR MTK (2.51 version) it saw the phone but showed

Device is in sleep mode
Need to wake it up!!!

Meanwhile my phone is on with me and not asleep

PLEASE WHAT CANI DO T FIX THIS?

if you're trying to root then disable dm_verity (method 3) @ https://forum.hovatek.com/thread-32719.html then patch boot using magisk @ https://forum.hovatek.com/thread-21427.html


RE: Blackview BV9600 pro Rooting - gabstar - 20-03-2021

(19-03-2021, 09:53 PM)X3non Wrote:  
(19-03-2021, 04:36 PM)gabstar Wrote:  Please I need help, trying to root and own my Blackview BV9600 pro, using fastboot, after unlocking and flashing on the device the custom recovery stil on the cmd fastboot I booted to the recovery but my device showed

Orange State
Your devices has been unlocked and can't be trusted
Your devices will boot in 5 seconds

Again I tried flash recovery, but fastboot devices refuse to identify my device and when I tried WwR MTK (2.51 version) it saw the phone but showed

Device is in sleep mode
Need to wake it up!!!

Meanwhile my phone is on with me and not asleep

PLEASE WHAT CANI DO T FIX THIS?

if you're trying to root then disable dm_verity (method 3) @ https://forum.hovatek.com/thread-32719.html then patch boot using magisk @ https://forum.hovatek.com/thread-21427.html

ADB and fastboot and Wwr MTK still not detecting my device even yjough it's the same PC I'v been using


RE: Blackview BV9600 pro Rooting - X3non - 22-03-2021

(20-03-2021, 11:38 PM)gabstar Wrote:  ADB and fastboot and Wwr MTK still not detecting my device even yjough it's the same PC I'v been using

wwr isn't meant to detect your device, if you're trying to backup firmware from your device then ensure to see https://forum.hovatek.com/thread-21970.html
for adb, ensure your device is booted to homescreen and you have usb debugging turned on and you accepted the debugging prompt
for fastboot, see https://forum.hovatek.com/thread-17105.html


RE: Blackview BV9600 pro Rooting - gabstar - 24-03-2021

(20-03-2021, 11:38 PM)gabstar Wrote:  
(19-03-2021, 09:53 PM)X3non Wrote:  
(19-03-2021, 04:36 PM)gabstar Wrote:  Please I need help, trying to root and own my Blackview BV9600 pro, using fastboot, after unlocking and flashing on the device the custom recovery stil on the cmd fastboot I booted to the recovery but my device showed

Orange State
Your devices has been unlocked and can't be trusted
Your devices will boot in 5 seconds

Again I tried flash recovery, but fastboot devices refuse to identify my device and when I tried WwR MTK (2.51 version) it saw the phone but showed

Device is in sleep mode
Need to wake it up!!!

Meanwhile my phone is on with me and not asleep

PLEASE WHAT CANI DO T FIX THIS?

if you're trying to root then disable dm_verity (method 3) @ https://forum.hovatek.com/thread-32719.html then patch boot using magisk @ https://forum.hovatek.com/thread-21427.html

ADB and fastboot and Wwr MTK still not detecting my device even yjough it's the same PC I'v been using


Trying to flash the vbmeta.img I got this error msg from fastboot that the partition doesn't exist.

C:\Users\platform-tools>fastboot flash vbmeta vbmeta.img
Sending 'vbmeta' (4 KB) OKAY [ 0.160s]
Writing 'vbmeta' FAILED (remote: 'This partition doesn't exist')
fastboot: error: Command failed


RE: Blackview BV9600 pro Rooting - gabstar - 24-03-2021

(22-03-2021, 09:31 AM)X3non Wrote:  
(20-03-2021, 11:38 PM)gabstar Wrote:  ADB and fastboot and Wwr MTK still not detecting my device even yjough it's the same PC I'v been using

wwr isn't meant to detect your device, if you're trying to backup firmware from your device then ensure to see https://forum.hovatek.com/thread-21970.html
for adb, ensure your device is booted to homescreen and you have usb debugging turned on and you accepted the debugging prompt
for fastboot, see https://forum.hovatek.com/thread-17105.html


Thanks, according to https://forum.hovatek.com/thread-17105.html i just needed to revoke all usb debugging. Tho still got This partition doesn't exist when i tried flashing vbmeta


RE: Blackview BV9600 pro Rooting - X3non - 24-03-2021

(24-03-2021, 02:43 AM)gabstar Wrote:  Thanks, according to https://forum.hovatek.com/thread-17105.html i just needed to revoke all usb debugging. Tho still got This partition doesn't exist when i tried flashing vbmeta

turns out that your device isn't android 9 or above, so you only need to patch boot using magisk to obtain root. link to magisk is in one of my previous replies


RE: Blackview BV9600 pro Rooting - gabstar - 26-03-2021

(24-03-2021, 10:03 AM)X3non Wrote:  
(24-03-2021, 02:43 AM)gabstar Wrote:  Thanks, according to https://forum.hovatek.com/thread-17105.html i just needed to revoke all usb debugging. Tho still got This partition doesn't exist when i tried flashing vbmeta

turns out that your device isn't android 9 or above, so you only need to patch boot using magisk to obtain root. link to magisk is in one of my previous replies

My device just won't stay connected for my to get out the boot.img from my current ROM, So I chat up Blackview Customer Services on Skype asking for ROM for my exact model and build number BV9600Pro_S700_V1.1_20190430V57 and I got this link

[ Login / Register to download free]

but my question now is that can I use the mahisk manager to patch the boot.img from this ROM and use on my device?

Okay I downloaded the ROM and unpacked it using WinRAR then patched the boot.img using magisk manager, but while flashing it using the fastboot I got an error msg that the partition doesn't exist:::

C:\Users\platform-tools-latest-windows\platform-tools>fastboot flash patched_boot patched_boot.img
target reported max download size of 134217728 bytes
sending 'patched_boot' (10983 KB)...
OKAY [ 1.059s]
writing 'patched_boot'...
FAILED (remote: This partition doesn't exist)
finished. total time: 1.425s

Does this mean the I was given isn't same with my current ROM?

Okay I just edited the name and tried again successfully ::::
C:\Users\platform-tools-latest-windows\platform-tools>fastboot boot recovery.img
downloading 'boot.img'...
OKAY [ 1.667s]
booting...
OKAY [ 0.155s]
finished. total time: 1.839s

Going check if it's rooted now.
I have root access not but still can't boot to recovery, rather the device boot to orange mode and later display No Command


RE: Blackview BV9600 pro Rooting - X3non - 27-03-2021

(26-03-2021, 12:41 PM)gabstar Wrote:  My device just won't stay connected for my to get out the boot.img from my current ROM, So I chat up Blackview Customer Services on Skype asking for ROM for my exact model and build number BV9600Pro_S700_V1.1_20190430V57 and I got this link

[ Login / Register to download free]

but my question now is that can I use the mahisk manager to patch the boot.img from this ROM and use on my device?

Okay I downloaded the ROM and unpacked it using WinRAR then patched the boot.img using magisk manager, but while flashing it using the fastboot I got an error msg that the partition doesn't exist:::

C:\Users\platform-tools-latest-windows\platform-tools>fastboot flash patched_boot patched_boot.img
target reported max download size of 134217728 bytes
sending 'patched_boot' (10983 KB)...
OKAY [ 1.059s]
writing 'patched_boot'...
FAILED (remote: This partition doesn't exist)
finished. total time: 1.425s

Does this mean the I was given isn't same with my current ROM?

Okay I just edited the name and tried again successfully ::::
C:\Users\platform-tools-latest-windows\platform-tools>fastboot boot recovery.img
downloading 'boot.img'...
OKAY [ 1.667s]
booting...
OKAY [ 0.155s]
finished. total time: 1.839s

Going check if it's rooted now.
I have root access not but still can't boot to recovery, rather the device boot to orange mode and later display No Command

the right command to flash to boot partition is
fastboot flash boot filename.img

whereas the "fastboot boot" command e.g below, simply boots the image without flashing, meaning that when you reboot the device, root will be lost
fastboot boot filename.img

in no command screen, you're to press power button + vol up (the combo might vary on your device) to proceed to recovery mode


RE: Blackview BV9600 pro Rooting - gabstar - 27-03-2021

(27-03-2021, 10:54 AM)X3non Wrote:  
(26-03-2021, 12:41 PM)gabstar Wrote:  My device just won't stay connected for my to get out the boot.img from my current ROM, So I chat up Blackview Customer Services on Skype asking for ROM for my exact model and build number BV9600Pro_S700_V1.1_20190430V57 and I got this link

[ Login / Register to download free]

but my question now is that can I use the mahisk manager to patch the boot.img from this ROM and use on my device?

Okay I downloaded the ROM and unpacked it using WinRAR then patched the boot.img using magisk manager, but while flashing it using the fastboot I got an error msg that the partition doesn't exist:::

C:\Users\platform-tools-latest-windows\platform-tools>fastboot flash patched_boot patched_boot.img
target reported max download size of 134217728 bytes
sending 'patched_boot' (10983 KB)...
OKAY [ 1.059s]
writing 'patched_boot'...
FAILED (remote: This partition doesn't exist)
finished. total time: 1.425s

Does this mean the I was given isn't same with my current ROM?

Okay I just edited the name and tried again successfully ::::
C:\Users\platform-tools-latest-windows\platform-tools>fastboot boot recovery.img
downloading 'boot.img'...
OKAY [ 1.667s]
booting...
OKAY [ 0.155s]
finished. total time: 1.839s

Going check if it's rooted now.
I have root access not but still can't boot to recovery, rather the device boot to orange mode and later display No Command

the right command to flash to boot partition is
fastboot flash boot filename.img

whereas the "fastboot boot" command e.g below, simply boots the image without flashing, meaning that when you reboot the device, root will be lost
fastboot boot filename.img

in no command screen, you're to press power button + vol up (the combo might vary on your device) to proceed to recovery mode

On the NoCommand screen I used the Vol+ and Power button but the device booted to bootloader options and when I selected recovery mode again I was back to Orange mode to no command, then I tried vol-and power button but that booted to Orange mode then normal system.

Any other option please?
Should I have to use fastboot to flash lock to avoid the Orange mode so I can get to recovery?
Or should I have to flash in the stock ROM to see if the TWRP I flashed in is the problem, if so will flashing in the stock recovery be ok with root retained?

I followed one of your links to edit lk.img and flashed on my bv9600pro it just remove the Orange State Display but won't still give access to recovery, I had to reflash on the device the stock lk.img and stock recovery.img and still can't boot to recovery. I'm guessing it's all as a result of the unlocking. Please any other way I fix this?