Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Solved] iNew L4 - MT6735P - boot loop after BusyBox Smart Install

#1

[SUBJECT]
---------
As the title of this post suggests that the phone (iNew L4) with me is now stuck at boot loop as bad as it doesn't bring up the recovery mode.

[AN OVERVIEW]
-------------
Before starting this thread let me tell you what led me to this state. I was trying to take full ROM backup from this phone which had been failed from various ways of trying [discussed here] https://forum.hovatek.com/thread-468-pos...l#pid59812 *** Finally I tried smart install of BusyBox via "BusyBox Pro" with all default options enabled as well as the clean mode and replace all options. It's purely my mistake as the BusyBox app warns when you enabled those options that if you don't know about it you should not enable them as it can damage system files. I just went on and tried them which first didn't fix the problem for which I tried that all but once after I turned off the phone, it never could boot up. It just started to display the initial splash logo screen for a few seconds and then restart over and over again. That too with no recovery mode available.

So I am starting this new thread as the original purpose of having a full ROM back is not possible until this gets fixed first and get life back. The new purpose is to get this phone back.

I did't have any kind of backup of this phone which I could flash back on it. As far as entering into recovery, I found the TWRP Port recovery.img for iNew L4 from needrom. Flashed it and the recovery actually worked. But for what? I didn't have anything to restore and the system image was already damaged and was not good to have a backup of.

[SOLUTION]
----------
Luckily, found the iNew L4's official 5.1 Lollipop ROM over at http://www.needrom.com/download/inew-l4-...-firmware/
Still wasn't sure if it will work but started downloading. (785MB)
Short story is that, this ROM worked good via flashing with SP Flash Tool.

[EXPERIMENTING WITH OTHER PHONE'S ROM - A PHONE WITH IDENTICAL HARDWARE]
----------------------------------------------------------------------------
Long Story: 785MB of official ROM could take up to an hour and a half to download but with a dead phone in hand I couldn't resist and first downloaded another ROM of Bluboo X550 (545MB) from http://www.needrom.com/download/bluboo-x550/ which was smaller in size so I thought it will download early and I could play with the TWRP recovery interface on the phone in the mean while.

I am mentioning about the Bluboo X550 ROM here because it's pretty much identical hardware to the iNew L4. Before thinking to download and flash some other phone's ROM I headed over and searched about the consequences and I found multiple topics where this was really not being advised to do that way. While being so curious that a ROM created for some hardware shouldn't be so different other than user interfaces, I preferred to try this ROM first. And beautifully the ROM actually got flashed on iNew L4 without any issues and it booted up with Bluboo splash logo with pretty much similar interface but with different themes and the navigation keys.

[HAPPY]
--------------
However once the original official ROM was downloaded and the phone is back with its official ROM. I disclosed everything above that may help others in similar issues.

[STILL TRYING FULL ROM BACKUP]
------------------------------
While this topic was created only for getting back the phone from somewhat a dead state, this phone still can not be backed up with MTK Droid Tools OR SP Flash Tool and I am heading back to the previous thread for this specific purpose over here https://forum.hovatek.com/thread-468-pos...l#pid59812


Reply










Users browsing this thread:
1 Guest(s)