Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Tecno N9 charging problem

#1

My Tecno N9 went completely dead yesterday and has refused to charge since then. It's screen just keeps flickering. How can I fix this, please?


Reply
#2
(12-29-2015, 02:52 PM)Munah Wrote: My Tecno N9 went completely dead yesterday and has refused to charge since then. It's screen just keeps flickering. How can I fix this, please?

did this just happen suddenly or it was after something you did?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
(12-29-2015, 07:19 PM)hovatek Wrote:
(12-29-2015, 02:52 PM)Munah Wrote: My Tecno N9 went completely dead yesterday and has refused to charge since then. It's screen just keeps flickering. How can I fix this, please?

did this just happen suddenly or it was after something you did?

It happened suddenly. I was using my phone as a modem via USB Tether when it happened. Before that, the battery had been draining very fast. So fast that when it is fully charged, it won't last 5 minutes before it would just turn off itself.
Reply
#4
(12-29-2015, 07:19 PM)hovatek Wrote:
(12-29-2015, 02:52 PM)Munah Wrote: My Tecno N9 went completely dead yesterday and has refused to charge since then. It's screen just keeps flickering. How can I fix this, please?

did this just happen suddenly or it was after something you did?

It happened suddenly while I was using the phone as a modem via USB Tether. Before that, the battery had been draining super fast. So fast that it wouldn't last a minute before shutting down after I disconnect the charger.
Reply
#5
(12-29-2015, 07:19 PM)hovatek Wrote:
(12-29-2015, 02:52 PM)Munah Wrote: My Tecno N9 went completely dead yesterday and has refused to charge since then. It's screen just keeps flickering. How can I fix this, please?

did this just happen suddenly or it was after something you did?

It happened suddenly while I was using the phone as a modem via USB Tether. Before that, the battery had been draining super fast. So fast that it wouldn't last a minute before shutting down after I disconnect the charger.

Reply
#6
(12-29-2015, 08:01 PM)Munah Wrote: It happened suddenly. I was using my phone as a modem via USB Tether when it happened. Before that, the battery had been draining very fast. So fast that when it is fully charged, it won't last 5 minutes before it would just turn off itself.

What you've described sounds like a drained battery. Have the battery taken out, boosted then clipped back in.
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#7
(12-30-2015, 01:45 PM)hovatek Wrote:
(12-29-2015, 08:01 PM)Munah Wrote: It happened suddenly. I was using my phone as a modem via USB Tether when it happened. Before that, the battery had been draining very fast. So fast that when it is fully charged, it won't last 5 minutes before it would just turn off itself.

What you've described sounds like a drained battery. Have the battery taken out, boosted then clipped back in.

Can I do that myself or I have to get to a technician?
Reply
#8
(12-30-2015, 01:45 PM)hovatek Wrote:
(12-29-2015, 08:01 PM)Munah Wrote: It happened suddenly. I was using my phone as a modem via USB Tether when it happened. Before that, the battery had been draining very fast. So fast that when it is fully charged, it won't last 5 minutes before it would just turn off itself.

What you've described sounds like a drained battery. Have the battery taken out, boosted then clipped back in.

Can I do that myself or I have to get to a technician?
Reply
#9
(12-30-2015, 02:02 PM)Munah Wrote: Can I do that myself or I have to get to a technician?

A technician. Or you keep charging.
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#10
U have to keeping on charging the bar3 it will come up or just go and buy a new I once have Dat same experience too I have to change the bar3
Reply










Users browsing this thread:
1 Guest(s)