Hi, Guest! Login / Register




Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Tutorial] How to fix unknown Baseband version, null / invalid IMEI & SIM card not detected


Am avin an unknown baseband,,invalid imei & not network issues with my tecno p5 after flashing a stock rom in2 the phone. But the main issue nw is after creating the MPOB_001 file ,I now copied and pasted it in2 d NVD_IMEI directory,,the new MPOB-001 still carries a back date of 2013 as shown in d picture. Plz is der anyway dis problem can be corrected??



Attached Files
.jpg   IMG_20151106_151247_edit.jpg (Size: 206.26 KB / Downloads: 11)
.jpg   IMG_20151106_151125_edit_edit_edit.jpg (Size: 382.98 KB / Downloads: 9)
Reply
(11-06-2015, 03:31 PM)johpWesh Wrote: Am avin an unknown baseband,,invalid imei & not network issues with my tecno p5 after flashing a stock rom in2 the phone. But the main issue nw is after creating the MPOB_001 file ,I now copied and pasted it in2 d NVD_IMEI directory,,the new MPOB-001 still carries a back date of 2013 as shown in d picture. Plz is der anyway dis problem can be corrected??

That shouldn't bother you. Just set the necessary permissions. You could use the Mobile uncle method
Reply
Tried everything,,i think that phone is wrecked!
Reply
(11-07-2015, 06:05 PM)johpWesh Wrote: Tried everything,,i think that phone is wrecked!

I doubt it
create a new thread so we focus on it

see https://forum.hovatek.com/thread-514.html for how to create a thread
Reply
(01-24-2014, 08:21 PM)hovatek Wrote: Quite a number of MTK users have been having this issue on their MTK devices after flashing one ROM or another; something i call the 'Custom ROM fever'. This issue is mostly caused by wiping / corruption of the data partition. The Baseband and radio (for network signal) are controlled by the NVRAM (located in data/nvram/md/NVRAM/NVD_IMEI) and a file called MP0B_001.
Once this file is missing or the NVRAM partiton is corrupted, your phone's IMEI and radio functionality cease to exist. There are several methods to fix this:

# See the video tutorial below or @ http://youtu.be/tAK1DL_L_eg 







*Note: 


+ Go to Settings > About and check Baseband. If it says Unknown then flash the Stock MTK backup using Sp flash tool @  https://forum.hovatek.com/thread-159.html to regain Baseband
+ For Samsung phones,  use this method @ http://forum.hovatek.com/showthread.php?tid=310

MP0B_001 Method

1. Download ROM toolbox lite from Playstore
2. Download IMEI.zip (to create a new IMEI file) then unzip the content of the folder (imei.exe) to a folder on your desktop
3. In command prompt, navigate to the imei.exe containing folder you just created on your desktop
* NOTE cd\ then enter (returns to root directory)
         
Code:
cd.. enter (goes up one directory) 
          
Code:
cd foldername enter (navigates to a folder called foldername) 
4. A faster method is to open the imei.exe containing folder > Hold down Shift > Right-click on an empty space > Select "Open Command Window here"
5. When you're inside the imei folder in command prompt, type
imei.exe <15digit_IMEI_1> <15digit_IMEI_2>
eg
 
Code:
imei.exe 123456789111111 123456789111124  
6. Press Enter          
7. If both IMEIs you gave are of the correct format, a file named MP0B_001_NEW will be created. Rename it MP0B_001.
8. Now you can send it to the sd of your phone
9. Install ROM toolbox lite then go to root explorer
10. In root explorer, delete the existing MP0B_001 file (located @ device/data/nvram/md/NVRAM/NVD_IMEI) and replace with the one you just created
11. Long press the new MP0B_001, go to permissions and tick all 9 boxes at the top then select ok (don't tick special pernissions)
12. Restart your phone
13. Your SIMs should be detected, IMEI reflect and Baseband version change from unknown to what it should be.
* Note that getting this done might not be this direct due to different scenarios but replacing the MP0B_001 file is the ultimate goal in order to fix the issue.

IMEI Replacement Method

This method involves the use of MTK droid tools and is only applicable when your SIM cards are detected but IMEI is invalid or null. To do this:

1. Download MTK droid tools
2. Download PdaNet
3. Enable USB debugging on the phone then connect it to the PC (don't enable mass storage)
4. Install PdaNet on the PC with the phone connected; you should get a message saying drivers installed successfully.
5. Extract then launch MTK droid tools on the PC (still with phone connected to PC)
6. MTK droid tools should detect and display your phones details
7. Click on IMEI/NVRAM
8. Supply the IMEI(s) then click replace
9. Restart your phone if it isn't automatically restarted
10. Your IMEI issue should have been resolved

NVRAM Restore Method

* Note that you need a working phone of the same model to backup NVRAM first

1. Download MTK droid tools
2. Download PdaNet
3. Enable USB debugging on the GOOD phone then connect it to the PC (don't enable mass storage)
4. Install PdaNet on the PC with the phone connected; you should get a message saying drivers installed successfully.
5. Extract then launch MTK droid tools on the PC (still with phone connected to PC)
6. MTK droid tools should detect and display your phones details
7. Click IMEI / NVRAM
8. Click Backup
9. When backup is complete, open the MTK Folder > BackupNVRAM to confirm that backup was successful
8. Connect the phone with Basebrand / IMEI error to the PC still with MTK droid tools open
9. Still under IMEI / NVRAM, click Restore
10. Select the appropriate files from the windows that pop up
11. Reboot the phone once the procedure is complete

Engineering Mode Method

1. Download and Install Mobile Uncle  then grant superuser permission
2. Select Engineer mode
3. Select Engineer mode (MTK)
4. Navigate to the Connectivity tab
5. Select CDS information
3. Select Radio Information

4. At Phone 1: Insert the command below then click Send at command

Code:
AT+EGMR=1,7,"IMEI1"

5. At Phone 2: Insert the command below then click Send at command

Code:
AT+EGMR=1,10,"IMEI2"

5a. If you get an error like "This command is not allowed in user build" then leave a space between AT+ and EGMR as show below

Code:
AT+ EGMR=The rest of the code

6. Go back to Mobile uncle home screen

7. Click on Engineer Mode
8. Select Engineer mode (Android)
9, Select Phone information
10.  Click Turn on radio


Stock ROM Method

1. Reflash the MTK backup using SP flash tool @  https://forum.hovatek.com/thread-159.html
2. After flashing, boot the phone into recovery mode, wipe data / factory reset
3. Wipe cache then remove the battery and slot back in
4. Reboot the phone
5. Try the MP0B method above again

NICE NICE NICE..................fix it thankssssss;D
Reply
PLS HELP ME OUT I BRICKED MY G5 PRESIDENT G6 DEVICE WHILE APPLYING A FONT. I DOWNLOADED THE ROM FROM GOOGLE DRIVE AND FLASHED WITH SP FLASH TOOL. THE RECOVERY AND UBOOT WERE NOT TICKED, AFTER THE FIRST FLASH, D PHONE REFUSED TO COME ON OR CHARGE. AFTER CHARGING FOR VERY LONG STILL NO RESPONSE, I FLASHED AGAIN, THIS TIME I MANUALLY CHOSE D UBOOT AND RECOVERY FILES. AFTER THAT, THE PHONED CAME ON WITH SOUND BUT THE DISPLAY IS BLURRED WHITE AND GREEN OR BLACK OR BLACK AND PURPLE. PLS HELP ME WITH LINK TO THE ROM AND WITH SUGGESTIONS ON HOW TO FIX THIS PROBLEM
Reply
(11-26-2015, 07:23 AM)EMMANUS Wrote: PLS HELP ME OUT I BRICKED MY G5 PRESIDENT G6 DEVICE WHILE APPLYING A FONT. I DOWNLOADED THE ROM FROM GOOGLE DRIVE AND FLASHED WITH SP FLASH TOOL. THE RECOVERY AND UBOOT WERE NOT TICKED, AFTER THE FIRST FLASH, D PHONE REFUSED TO COME ON OR CHARGE. AFTER CHARGING FOR VERY LONG STILL NO RESPONSE, I FLASHED AGAIN, THIS TIME I MANUALLY CHOSE D UBOOT AND RECOVERY FILES. AFTER THAT, THE PHONED CAME ON WITH SOUND BUT THE DISPLAY IS BLURRED WHITE AND GREEN OR BLACK OR BLACK AND PURPLE. PLS HELP ME WITH LINK TO THE ROM AND WITH SUGGESTIONS ON HOW TO FIX THIS PROBLEM

Create a new thread so we focus on it.
Reply
Hello, my friend's phone looses network and the two sim indicators will be showing a red search symbol.
can I follow the engineering mode method to fix this problem?
Reply
(11-26-2015, 03:28 PM)nearestemmanuel Wrote: Hello, my friend's phone looses network and the two sim indicators will be showing a red search symbol.
can I follow the engineering mode method to fix this problem?

does the phone have a Baseband?
Reply
Hello admin... Can this tutorial solve a problem on Samsung Galaxy Tab GT-P5200? My brother mistakenly wipe his without baking it up, and installed a custom rom.

The custom rom is working smoothly, but the phone is not bringing up a network... Always saying "NOT REGISTERED ON NETWORK" whenever I dailed numbers on it.

The custom rom has baseband and imei intact... But I noticed the "EFS PARTITION and RADIO PARTITION are no where to found on the phone... How can I fixed the EFS PARTITION and the RADIO PARTITION?

NOTE:ive tried many official stock roms from SAMMOBILE, SAMSUNG FIRMWARE AND SAMSUNG UPDATES... I've also tried NEEDROM, but I couldn't get the rom for GT-P5200.


Thanks.
Reply










Users browsing this thread:
2 Guest(s)