Hi, Guest! Login / Register

We're Recruiting: Applicants must possess hardware repair skills. Email [email protected] (Jan, 2018)
Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Tutorial] How to fix Unknown Baseband, NULL or Invalid IMEI & SIM / Network not detected on MTK


bro, i wanna ask a question, before you list the processes you said the baseband number should be checked, well I checked mine and it's empty, nothing was there, my question is can I continue with the step to fix the IMEI or I have to return my phone to the stock rom as you said, cos I just changed my rom to a custom rom
Reply
(10-12-2017, 12:44 AM)thoblex Wrote: bro, i wanna ask a question, before you list the processes you said the baseband number should be checked, well I checked mine and it's empty, nothing was there, my question is can I continue with the step to fix the IMEI or I have to return my phone to the stock rom as you said, cos I just changed my rom to a custom rom

Baseband needs to be regained first by reflashing the stock rom or at least secro & NVRAM
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
OK, thanks bro, so after regaining the baseband number, can I still change the stockfirmware to the custom rom I loved so much, and how can I do it without affecting the baseband number.
Actually, I thought of it that I could do nandroid backup of this current custom rom and will restore it after the sp flashtool wahala, please will it work?
Reply
(10-13-2017, 02:28 AM)thoblex Wrote: OK, thanks bro, so after regaining the baseband number, can I still change the stockfirmware to the custom rom I loved so much, and how can I do it without affecting the baseband number.
Actually, I thought of it that I could do nandroid backup of this current custom rom and will restore it after the sp flashtool wahala, please will it work?

There are some steps you still need to take
Please, create a new thread so we focus on this case
see https://forum.hovatek.com/thread-514.html for how to create a thread
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply


(05-01-2014, 05:27 PM)abdullahi_ Wrote: HOW I SURVIVE/FIX AN UNKNOWN BASEBAND/RADIO/INVALID-IMEI  ON MY TECNO M3


So it all goes like this, i just accidentally execute the init binary, in seconds all i know is my phone rebooting itself with unknown baseband. surprise to me , what goes wrong?.  so i went after the su log file to read the log and i was able to verify what happen, when  init tries to creates the radio folder (/protect_f and /protect_s) which contains the radio files, it founds out that it was busy so it delete the former one to create the new one deleting the old one with the files but hopefully i've once backup the whole init and the radio folder to my sdcard . so all i have to do is copy the files (MP0D_000 and ST33A004 from the /protect_s/md/ directory that i copied ) to /protect_f/md/ directory , which automagically create another twin file of ST33A004 in /protect_s/md/ directory called ST33B004 and immediately my phone alerting that it has detected a network so all i do is to confirm by clicking ok. thatz all


Apply this method only if you restore your IMEI and it doesnt work or if you have an unknown baseband/radio problem/invalid imei.........!!!

please can you explain better
Reply
Hello can someone help me I tried a lot of method but my baseband is always unknown I also tried flashing stock rom but I noticed something weird. Every time I wait for about 4-6 hours after reboot I can see my baseband and original imei restored. However Everytime I reboot, the basebands always becomes unknown.and sometimes I wait but sometimes my baseband doesn't restore. Would appreciate any help thx

Sent from my Lenovo A7010a48 using Tapatalk
Reply
(11-29-2017, 07:37 AM)cyrontrinidad Wrote: Hello can someone help me I tried a lot of method but my baseband is always unknown I also tried flashing stock rom but I noticed something weird. Every time I wait for about 4-6 hours after reboot I can see my baseband and original imei restored. However Everytime I reboot, the basebands always becomes unknown.and sometimes I wait but sometimes my baseband doesn't restore. Would appreciate any help thx

Sent from my Lenovo A7010a48 using Tapatalk

Please, create a new thread so we focus on it
see https://forum.hovatek.com/thread-514.html for how to create a thread
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply









Users browsing this thread:
3 Guest(s)