Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Tool] SPFlashtools scatter loading error ( NO NOOB real problem )

#1
Question  (This post was last modified: 01-18-2015, 04:36 AM by the_grinch. )

Hi guys,

I have a Jiayu S2 MT6592. I wanted to make a full backup of my rom. (system + cache + user data etc..)
With the new version of SP Flashtool ( SP_Flash_Tool_exe_Windows_v5.1416.00 ), I did it !
I also made files for SP Flashtool thanks to MTKDroidtool.

You can find the full scatter here : http://pastebin.com/vBP89vjB
For the backup, I stopped to FAT partition.
Code:
for userdata
  linear_start_addr: 0x 4580 0000
  physical_start_addr: 0x 4580 0000
  partition_size: 0x1 0000 0000

FAT
linear_start_addr: 0x 1 4580 0000

My files :
[Image: HLVHZAm.jpg]

You see, I have every files and the scatter is correct.

But when I load the scatter into SP Flashtool, Flashtool isnt able to load my data.img with correct adresses ...

[Image: 020obw1.jpg]

I already tried to load manually but it doesnt work.

Could you help me ?
I really would like to backup and restore my whole phone with all data. ( really FULL backup )

Thank you very much.


Reply
#2
(This post was last modified: 01-18-2015, 11:57 AM by hovatek. )
(01-18-2015, 04:35 AM)the_grinch Wrote: Hi guys,

I have a Jiayu S2 MT6592. I wanted to make a full backup of my rom. (system + cache + user data etc..)
With the new version of SP Flashtool ( SP_Flash_Tool_exe_Windows_v5.1416.00 ), I did it !
I also made files for SP Flashtool thanks to MTKDroidtool.

You can find the full scatter here : http://pastebin.com/vBP89vjB
For the backup, I stopped to FAT partition.





Code:
for userdata
 linear_start_addr: 0x 4580 0000
 physical_start_addr: 0x 4580 0000
 partition_size: 0x1 0000 0000

FAT
linear_start_addr: 0x 1 4580 0000

My files :
[Image: HLVHZAm.jpg]

You see, I have every files and the scatter is correct.

But when I load the scatter into SP Flashtool, Flashtool isnt able to load my data.img with correct adresses ...

[Image: 020obw1.jpg]

I already tried to load manually but it doesnt work.

Could you help me ?
I really would like to backup and restore my whole phone with all data. ( really FULL backup )

Thank you very much.

I see that recovery and ubootare also not selected.

For recover, you need to rename from factory_NONmodified_recovery.img  to just recovery , then it'll be loaded
For Usrdata (data.img) , you need to edit your scatter file. in your scatter, look for the part that looks like this

Code:
partition_index: SYS18
  partition_name: USRDATA
  file_name: NONE
  is_download: true
  type: NORMAL_ROM
  linear_start_addr: 0x45800000
  physical_start_addr: 0x45800000
  partition_size: 0x100000000
  region: EMMC_USER
  storage: HW_STORAGE_EMMC
  boundary_check: true
  is_reserved: false
  operation_type: UPDATE
  reserve: 0x00

and edit it to

Code:
partition_index: SYS18
  partition_name: USRDATA
  file_name: data.img
  is_download: true
  type: NORMAL_ROM
  linear_start_addr: 0x45800000
  physical_start_addr: 0x45800000
  partition_size: 0x100000000
  region: EMMC_USER
  storage: HW_STORAGE_EMMC
  boundary_check: true
  is_reserved: false
  operation_type: UPDATE
  reserve: 0x00

The line you change is from  file_name: NONE to file_name: data.img
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
(This post was last modified: 01-18-2015, 10:59 AM by the_grinch. )
Hi, Thank you for your replying !

I dont need recovery, it's not the most important ( I already have a stock rom with the recovery)

I didn't make the FAT backup (I stopped at the FAT starting adress..), only the user data and in the scatter, it's already good :

You can see :

Quote:- partition_index: SYS18
partition_name: USRDATA
file_name: data.img
is_download: true
type: NORMAL_ROM
linear_start_addr: 0x45800000
physical_start_addr: 0x45800000
partition_size: 0x100000000
region: EMMC_USER
storage: HW_STORAGE_EMMC
boundary_check: true
is_reserved: false
operation_type: UPDATE
reserve: 0x00

and " is_download: true" in green is well on "true". It should be loaded.. but it doesnt !

And " partition_size: 0x100000000 " is well equals to "4294967296 bytes" about the size of my data.img.

Thank you very much. Maybe it's just a SPFlashTool problem... maybe I just need to wait that developers solve this problem.
Reply
#4
(This post was last modified: 01-18-2015, 05:25 PM by hovatek. )
(01-18-2015, 10:51 AM)the_grinch Wrote: Hi, Thank you for your replying !

I dont need recovery, it's not the most important ( I already have a stock rom with the recovery)

I didn't make the FAT backup (I stopped at the FAT starting adress..), only the user data and in the scatter, it's already good :

You can see :


Quote:- partition_index: SYS18
 partition_name: USRDATA
 file_name: data.img
is_download: true
 type: NORMAL_ROM
 linear_start_addr: 0x45800000
 physical_start_addr: 0x45800000
 partition_size: 0x100000000
 region: EMMC_USER
 storage: HW_STORAGE_EMMC
 boundary_check: true
 is_reserved: false
 operation_type: UPDATE
 reserve: 0x00

and " is_download: true" in green is well on "true". It should be loaded.. but it doesnt !

And " partition_size: 0x100000000 " is well equals to "4294967296 bytes" about the size of my data.img.

Thank you very much. Maybe it's just a SPFlashTool problem... maybe I just need to wait that developers solve this problem.

really sorry for the mix up. mistakenly copied out the FAT section of the scatter file instead of user data. I see the usrdata part of the scatter file is ok so its quite weird thats its not getting loaded
userdata should normally work. just used version 5.1343 (though its named userdata.img in gionee) and it loaded fine.
try another version of SP flash tool and see if it helps.
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
Yes ... it's really weird..

I tried changing file name and the name in the scatter file (data.img => userdata.img like in older scatter version) but same problem...

Maybe it's a problem of size... older versions below 5.1416 didnt allow me to make a backup of my user data...

I'll try with older SP Flash tool versions.

I take you in touch !

Reply
#6
Hi !
I tried with the 5.1343 version but it doesnt work ... same problem.
The most strange is with my stock rom (userdata.img does 70MB), it works.

Then I'm thinking it's because SP Flash Tool doesnt work with big length ( 0x 1 0000 0000 ) 9 digits against 8digits for every other partitions.

I tried to look for on internet but nothing... To believe that I'm the first one trying this...

When found, I'll post here the solution, otherwise if you have another idea, feel free to send it here!!

Thank you.

(sorry for the English, I'm French living in Japan ><)
Reply
#7
(01-19-2015, 01:05 AM)the_grinch Wrote: Hi !
I tried with the  5.1343 version but it doesnt work ... same problem.
The most strange is with my stock rom (userdata.img does 70MB), it works.

Then I'm thinking it's because SP Flash Tool doesnt work with big length ( 0x 1 0000 0000 ) 9 digits against 8digits for every other partitions.

I tried to look for on internet but nothing... To believe that I'm the first one trying this...

When found, I'll post here the solution, otherwise if you have another idea, feel free to send it here!!

Thank you.

(sorry for the English, I'm French living in Japan ><)

had this very issue during readbacks too. data.img wouldnt be copied alongside the rest and had to be readback manually. usually got this at data.img nearing 2GB in size. keep us posted on how it goes
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#8
Oh, it's maybe a good idea to readback separately from the whole rom.
I'm gonna try and I keep you in touch !

Just for me, the size written in the scatter file is correct and on Android, the size is well 4GB. maybe just a readback issue.
Reply
#9
(This post was last modified: 01-20-2015, 01:35 PM by the_grinch. )
Ok, it's not possible to readback only the USERDATA or anyother partitions separately. It makes an error when MTKDroidTool prepares files...
I'll try to make a full backup from 0 to FAT. I'll see...

Thank you again for your idea Wink
Reply
#10
(01-20-2015, 01:34 PM)the_grinch Wrote: Ok, it's not possible to readback only the USERDATA or anyother partitions separately. It makes an error when MTKDroidTool prepares files...
I'll try to make a full backup from 0 to FAT. I'll see...

Thank you again for your idea Wink

it's very possible to readback one partiton at a time. its for full dump you'll need mtk droid tools. you dont need mtk droid tools when dumping one file/partition at a time. see this guide @ https://forum.hovatek.com/thread-526.html . You can also see the video at that link.
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)