Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Dead infinix hot X507 device

#1

Hovatek thanks for your good work.  pls I need your help, my infinix hot X507 is dead, I downloaded the lollipop stock rom from xclub, [infinix website) and I was flashing it with special flash tools when the process was interrupted, the phone went dead instantly, won't turn on and pc won't recognize it. I retried it several times and now the phone will turn on, show a blank screen, wait for some seconds, go off, turn on again, wait for some seconds, then go off again, it keeps repeating the process, when I try to flash it with special flash tools it says one of the USB devices attached to this computer is not recognized, one would think it's the USB device but it's not because I tried to flash another infinix hot X507 and it worked fine, but this dead infinix hot X507  won't flash. Pls  i need ur help. Thanks in advance.


Reply
#2
(03-02-2016, 11:32 AM)Kindness Wrote: Hovatek thanks for your good work.  pls I need your help, my infinix hot X507 is dead, I downloaded the lollipop stock rom from xclub, [infinix website) and I was flashing it with special flash tools when the process was interrupted, the phone went dead instantly, won't turn on and pc won't recognize it. I retried it several times and now the phone will turn on, show a blank screen, wait for some seconds, go off, turn on again, wait for some seconds, then go off again, it keeps repeating the process, when I try to flash it with special flash tools it says one of the USB devices attached to this computer is not recognized, one would think it's the USB device but it's not because I tried to flash another infinix hot X507 and it worked fine, but this dead infinix hot X507  won't flash. Pls  i need ur help. Thanks in advance.

Unplug the battery and plug back then try reflashing you can as well try another USB cord just to be sure
Reply
#3
I have fixed that issue, but now I'm having another problem with the device, when I try flashing it with special flash tool, it's stuck at downloading flash, it just stays at 0% for long, how do I fix this, thanks in advance.
Reply
#4
(03-02-2016, 02:43 PM)Kindness Wrote: I have fixed that issue, but now I'm having another problem with the device, when I try flashing it with special flash tool, it's stuck at downloading flash, it just stays at 0% for long, how do I fix this, thanks in advance.

See here https://forum.hovatek.com/thread-439.html
Reply
#5
(03-02-2016, 02:43 PM)Kindness Wrote: I have fixed that issue, but now I'm having another problem with the device, when I try flashing it with special flash tool, it's stuck at downloading flash, it just stays at 0% for long, how do I fix this, thanks in advance.

ensure to install VCOM drivers using https://forum.hovatek.com/thread-440.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)