Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] I need help mtk died device

#1
Sad 

hello forum, I need help, my MTK device seems to have died , try desbrikearlo but something went wrong because when I finish the process no longer lit , only vibro , then try to flash it again, but it got worse because now no longer vibrates , as does nothing helps please ...

P.S. sorry for my English so bad


Reply
#2
(03-04-2016, 06:32 PM)Andy1234 Wrote: hello forum, I need help, my MTK device seems to have died , try desbrikearlo but something went wrong because when I finish the process no longer lit , only vibro , then try to flash it again, but it got worse because now no longer vibrates , as does nothing helps please ...

P.S. sorry for my English so bad

Whats the model of your phone?
Reply
#3
huawey y330 u05
Reply
#4
(This post was last modified: 03-04-2016, 07:18 PM by matybazz. )
(03-04-2016, 07:05 PM)Andy1234 Wrote: huawey y330 u05

Ok try charging your battery externally
This sould solve your issue
https://forum.hovatek.com/thread-485.html
Reply
#5
(03-04-2016, 07:05 PM)Andy1234 Wrote: huawey y330 u05

have youu downloaded the stock ROM / firmware for your phone model?
Need further assistance? Speak with a Hovatek Representative:

Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)

Request for Private Support
* Install the Hovatek Forum app
* Listen to H-Tech Radio
* Helpline: +2348021840309
* Email: [email protected]
* Skype: Hovatek
Reply










Users browsing this thread:
1 Guest(s)