Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] MY INFINIX X507 NO LONGER DISPLAY SERVICE. NO SIGNAL STRENGHT BUT SIMCARD IS DETECTED

#1

Please, I'm soliciting for your help. My INFINIX x507 ceased displaying service after an attempt to upgrade to lollipop version through the update i saw on my phone, but wasn't successful, because my phone ran out of power. Though my baseband and IMEI are all intact. but, each time i reboot the phone, the signal strength shows a sign as if it wants to come up but turns down at the end.... i did a root with king root before the upgrade. thanks


Reply
#2
(03-19-2016, 08:08 PM)Exone Wrote: Please, I'm soliciting for your help. My INFINIX x507 ceased displaying service after an attempt to upgrade to lollipop version through the update i saw on my phone, but wasn't successful, because my phone ran out of power. Though my baseband and IMEI are all intact. but, each time i reboot the phone, the signal strength shows a sign as if it wants to come up but turns down at the end.... i did a root with king root before the upgrade. thanks

have you tried reflashing the firmware @ https://forum.hovatek.com/thread-533.html using SP flash tool @ https://forum.hovatek.com/thread-159.html?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
Thanks for the response. No, i haven't tried flashing the firmware yet. But i tried with the SP FLASH TOOL method before your reply, to do a backup of my ROM and then flash it once the backup was successful but it was not. During the process, this was the error message prompted when i tried to "readback" the file i created.

Attached Files
.png   Screenshot - 3_20_2016 , 4_08_07 London.png (Size: 102.87 KB / Downloads: 1)
Reply
#4
(03-21-2016, 12:39 AM)Exone Wrote: Thanks for the response. No, i haven't tried flashing the firmware yet. But i tried with the SP FLASH TOOL method before your reply, to do a backup of my ROM and then flash it once the backup was successful but it was not. During the process, this was the error message prompted when i tried to "readback" the file i created.

Flash the firmware following the links in my previous comment
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
OK. thanks alot
Reply
#6
Photo 
Good afternoon @ Hovatek. thanks for the previous guide. i've finally followed your link to download the STOCK BACKUP for my infinix x507. But i couldn't go ahead to flash the "firmware" as you instructed beacuse there were no files for CACHE and USRDATA in the STOCK BACKUP i downloaded, and since all flashing files have to be present and ticked before considering a "firmware flash" but instead i went for "download only". Imemediately i hit the download button and connected my switched-off phone, there was a red progress bar which ran across and followed by an error prompted reading; "PMT changed for the ROM; it must be downloaded"...... How do i fix this please

Attached Files
.png   ERROR.png (Size: 195.3 KB / Downloads: 0)
Reply
#7
(03-25-2016, 02:36 PM)Exone Wrote: Good afternoon @ Hovatek. thanks for the previous guide. i've finally followed your link to download the STOCK BACKUP for my infinix x507. But i couldn't go ahead to flash the "firmware" as you instructed beacuse there were no files for CACHE and USRDATA in the STOCK BACKUP i downloaded, and since all flashing files have to be present and ticked before considering a "firmware flash" but instead i went for "download only". Imemediately i hit the download button and connected my switched-off phone, there was a red progress bar which ran across and followed by an error prompted reading; "PMT changed for the ROM; it must be downloaded"...... How do i fix this please

Userdata and cache are optional. Format first then download only. Refer to https://forum.hovatek.com/thread-439.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#8
Good pm. please i have done the flashing with your stock backup and now am faced with double challenges. One is the previous "no signal problem", and two is the NVRAM Warning error. But my major problem is the signal not coming up on my phone at all. Am totally confused because ever since i bricked the phone by not successfully upgrading to Lollipop version, it tends to show service in some areas and not in other areas. The annoying thing is the carrier name being present but no signal strength. Do i need a complete backup to upgrade the firmware or can't there be just a way out? please help me to see to this. i feel like am losing the phone already
Reply
#9
Good pm. please i have done the flashing with your stock backup and now am faced with double challenges. One is the previous "no signal problem", and two is the NVRAM Warning error. But my major problem is the signal not coming up on my phone at all. Am totally confused because ever since i bricked the phone by not successfully upgrading to Lollipop version, it tends to show service in some areas and not in other areas. The annoying thing is the carrier name being present but no signal strength. Do i need a complete backup to upgrade the firmware or can't there be just a way out? please help me to see to this. i feel like am losing the phone already
Reply
#10
and i wonder why the device is poping tekno p5 plus when plugged but when checked from my computer, it's still the infinix phone. i guess the backup was for tekno p5 plus. please i'm still here and i need your kind help. thank you
Reply










Users browsing this thread:
1 Guest(s)