Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Totally dead infinix hot x507

#1

I was trying to upgrade my phone to lollipop via sp flash tools, I have all necessary drivers installed as this is not my first time of doing this. I connected my phone as usual and hit the download button without battery, before I could insert my battery my system pops the sound that my device is removed. I tried again and again with another system and USB cable but no response. Please help as I can't turn on or charge my x507.....no sign of life at all. If anyone has gone through this in the past, please help.


Reply
#2
And BTW, I have the stock rom backup and I tried flashing but the phone disconnects itself before flashing after the red bar in sp flash tools.
Reply
#3
(03-23-2016, 05:52 PM)Frabjous Wrote: And BTW, I have the stock rom backup and I tried flashing but the phone disconnects itself before flashing after the red bar in sp flash tools.

You interrupted flash and also you should leave battery in the phone when trying to flash next time see here for fix https://forum.hovatek.com/thread-808.html
Reply
#4
(03-23-2016, 05:59 PM)matybazz Wrote:
(03-23-2016, 05:52 PM)Frabjous Wrote: And BTW, I have the stock rom backup and I tried flashing but the phone disconnects itself before flashing after the red bar in sp flash tools.

You interrupted flash and also you should leave battery in the phone when trying to flash next time see here for fix https://forum.hovatek.com/thread-808.html

May be you are Right, but I didn't interrupt it, My system indicates that the device x507 has been removed. l didn't touch anything during flashing, and I have a good USB cord. I also tried flashing with battery but after seconds I receive the 5054 error. which means I'm not flashing the correct files for my phone. what can I do next? charge for long hours or download your stock ROM. and try again.
Reply
#5
(03-23-2016, 07:36 PM)Frabjous Wrote:
(03-23-2016, 05:59 PM)matybazz Wrote:
(03-23-2016, 05:52 PM)Frabjous Wrote: And BTW, I have the stock rom backup and I tried flashing but the phone disconnects itself before flashing after the red bar in sp flash tools.

You interrupted flash and also you should leave battery in the phone when trying to flash next time see here for fix https://forum.hovatek.com/thread-808.html

May be you are Right, but I didn't interrupt it, My system indicates that the device x507 has been removed. l didn't touch anything during flashing, and I have a good USB cord. I also tried flashing with battery but after seconds I receive the 5054 error. which means I'm not flashing the correct files for my phone. what can I do next? charge for long hours or download your stock ROM. and try again.
Reply
#6
(03-24-2016, 12:07 PM)Frabjous Wrote: May be you are Right, but I didn't interrupt it, My system indicates that the device x507 has been removed. l didn't touch anything during flashing, and I have a good USB cord. I also tried flashing with battery but after seconds I receive the 5054 error. which means I'm not flashing the correct files for my phone. what can I do next? charge for long hours or download your stock ROM. and try again.

remove the battery and reinsert then reflash using the firmware @ https://forum.hovatek.com/thread-533.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#7
OK.... I'll do that. But my phone is currently plugged to a wall socket where power supply is 24/7... I can only collect my phone until Tuesday. Will download the file asap. Thanks.
Reply
#8
My phone has shown a bit of life after I plugged it to a wall socket for 2-3 days. Now, I plugged it in my system and shows battery charging from 0%. I was told to let it charge up to 50%. Please can I Still flash the lollipop upgrade or the mtk stock backup I created. Because currently I don't have enough data to download the stock ROM from this website.
Reply
#9
(03-26-2016, 09:52 AM)Frabjous Wrote: My phone has shown a bit of life after I plugged it to a wall socket for 2-3 days. Now, I plugged it in my system and shows battery charging from 0%. I was told to let it charge up to 50%. Please can I Still flash the lollipop upgrade or the mtk stock backup I created. Because currently I don't have enough data to download the stock ROM from this website.

let the phone charge as instructed then flash the mtk backup you created
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#10
Thanks to hovatek.....I flashed the lollipop ROM after hours of charging. The phone is working fine now.If you experience the same problem, just charge for long hours and reflash.
Reply










Users browsing this thread:
1 Guest(s)