Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Infinix hot 2 X510 No longer powering on though I got a Download Ok notification

#11
Information 

(03-30-2016, 01:41 PM)TsatsuJnr Wrote: Hi, please I flashed a stock rom for an infinix hot 2 X510 1 GIG version using sp flash tool, and my phone is no longer powering on though i got a download okay notification, and now when I connect my phone to the pc via usb cord it just keeps disconnecting and reconnecting....Any assistance will be much appreciated

1.where did you got the rom you flashed?
2. what happens when you try reflashing it? does it agree to download? if yes,use the firmware upgrade instead of download. let me know if you succeed.


Reply
#12
I got the ROM from hovateks collection, and the phone is not detected as a mediatek device in device manager but a USB serial device and it keeps disconnecting and reconnecting every few seconds, when I try reflashing by connecting the the phone after clicking the download button in SP flash tool then connecting the phone it gives me BROM ERROR S_FT_ENABLE_DRAM_FAIL(4032) [EMI] Enable DRAM fail
Reply
#13
(04-01-2016, 01:32 PM)TsatsuJnr Wrote: I got the ROM from hovateks collection, and the phone is not detected as a mediatek device in device manager but a USB serial device and it keeps disconnecting and reconnecting every few seconds, when I try reflashing by connecting the the phone after clicking the download button in SP flash tool then connecting the phone it gives me BROM ERROR S_FT_ENABLE_DRAM_FAIL(4032) [EMI] Enable DRAM fail

Are you sure you're flashing your phone's ROM?
if yes Format it first from sp flash tool before flashing the ROM.
Reply
#14
Same error when trying to format first
Reply
#15
(04-01-2016, 07:01 PM)TsatsuJnr Wrote: Same error when trying to format first

Download another version of SP flash tool...
Don't put battery in phone until you've pressed download, then immediately slot in the battery.
Reply
#16
Thanks, I just tried that but it doesn't seem to work, Still getting the same error
Is it normal for the USB to be connecting and disconnecting every few seconds and the device is not detected as preloader Mediatek device but MTK USB Port
Reply
#17
mtk drivers not mannually set well or your usb port may be loose
Reply
#18
Thanks for your help guys I've been able to to get it to work, your effort is much appreciated
Reply
#19
Am having having a issue with my infinix hot2 2gb ram
Reply
#20
Am having the same issue with my infinix hot2 2gb ram. Don't know what to do.
Reply










Users browsing this thread:
1 Guest(s)