Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Infinix hot 2 X510 No longer powering on though I got a Download Ok notification

#1

Hi, please I flashed a stock rom for an infinix hot 2 X510 1 GIG version using sp flash tool, and my phone is no longer powering on though i got a download okay notification, and now when I connect my phone to the pc via usb cord it just keeps disconnecting and reconnecting....Any assistance will be much appreciated


Reply
#2
(03-30-2016, 01:41 PM)TsatsuJnr Wrote: Hi, please I flashed a stock rom for an infinix hot 2 X510 1 GIG version using sp flash tool, and my phone is no longer powering on though i got a download okay notification, and now when I connect my phone to the pc via usb cord it just keeps disconnecting and reconnecting....Any assistance will be much appreciated

* whats the RAM size of the phone?
* which stock rom did you flash?
Reply
#3
My phone is the 1 gig ram version and I flashed the rom for the same version from your collection of stock roms
Reply
#4
(03-30-2016, 10:48 PM)TsatsuJnr Wrote: My phone is the 1 gig ram version and I flashed the rom for the same version from your collection of stock roms

Take out the battery and reinsert then leave the phone to charge
Reply
#5
Okay, so I should just keep charging and eventually it'll power on?
Reply
#6
(03-31-2016, 10:29 AM)TsatsuJnr Wrote: Okay, so I should just keep charging and eventually it'll power on?

yes. the phone would eventually show the charging battery sign
Reply
#7
Okay,thanks and is there a definite time after which I should have expect to see it
Reply
#8
(03-31-2016, 02:01 PM)TsatsuJnr Wrote: Okay,thanks and is there a definite time after which I should have expect to see it

Less than 1 hour
Reply
#9
Well I've been charging it for more than a day now still no life, andis there a reason for the USB disconnecting and reconnecting constantly from the pc
Reply
#10
(03-31-2016, 10:30 PM)TsatsuJnr Wrote: Well I've been charging it for more than a day now still no life, andis there a reason for the USB disconnecting and reconnecting constantly from the pc

Take out the battery and reinsert.
Refer to https://forum.hovatek.com/thread-439.html
Reply










Users browsing this thread:
1 Guest(s)