Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] infinix x600 wont power on

#1
Exclamation 

guys i kindly need your assistance.
i bricked my infinix note 2 totally and i used the solution in this forum to wake it up. thankfully my PC now detects my phone n it charges alright and i ve successfully flashed the correct firmware or ROM but still my phone don't power on.
although it charges....
any help.. waiting for your assistance


Reply
#2
(04-04-2016, 02:16 AM)georgekmen Wrote: guys i kindly need your assistance.
i bricked my infinix note 2 totally and i used the solution in this forum to wake it up. thankfully my PC now detects my phone n it charges alright and i ve successfully flashed the correct firmware or ROM but still my phone don't power on.
although it charges....
any help.. waiting for your assistance

did flashing succeed? did you use the loop wire on vcc and ground terminal? if yes,after flashing did you remove it?
Reply
#3
(04-04-2016, 07:25 AM)jospah prezz Wrote:
(04-04-2016, 02:16 AM)georgekmen Wrote: guys i kindly need your assistance.
i bricked my infinix note 2 totally and i used the solution in this forum to wake it up. thankfully my PC now detects my phone n it charges alright and i ve successfully flashed the correct firmware or ROM but still my phone don't power on.
although it charges....
any help.. waiting for your assistance

did flashing succeed? did you use the loop wire on vcc and ground terminal? if yes,after flashing did you remove it?

Yes flashing succeeded and after successful connection between the ground and force pin out I disconnected the wire..when I press power nothing happens now..but am able to charge and flash again

Sent from my GT-N7105 using Hovatek mobile
Reply
#4
(04-04-2016, 08:03 AM)georgekmen Wrote: Yes flashing succeeded and after successful connection between the ground and force pin out I disconnected the wire..when I press power nothing happens now..but am able to charge and flash again

Sent from my GT-N7105 using Hovatek mobile

did you check your phones model and the stock rom's model before downloading and flashing?
H532-A1
H533-A1
H533-B1

refer to https://forum.hovatek.com/thread-11899.html
Reply
#5
Yes I did and I ve the correct firmware

Sent from my GT-N7105 using Hovatek mobile
Reply
#6
I feel that my power button is dead or spoilt. When I connect phone to charger it charges correctly and even with PC it tries to install mtp device drivers.. when I press the power button or any volume button nothing happens.
I feel it was damaged. Is there no possible ways to switch on the phone with a hardware connection?

Sent from my GT-N7105 using Hovatek mobile
Reply
#7
(04-05-2016, 02:54 AM)georgekmen Wrote: I feel that my power button is dead or spoilt. When I connect phone to charger it charges correctly and even with PC it tries to install mtp device drivers.. when I press the power button or any volume button nothing happens.
I feel it was damaged. Is there no possible ways to switch on the phone with a hardware connection?

Sent from my GT-N7105 using Hovatek mobile

you should have the power button checked by a phone engineer.
Reply
#8
Yes I did and the board is damaged and needs to be replaced

Sent from my GT-N7105 using Hovatek mobile

Reply










Users browsing this thread:
1 Guest(s)