Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Need some help on Infinix x510 1gb

#1

If I charge the battery full and I leave it for few hours the battery will be dead and the phone is not even powering on again is there any help....?

Sent from my E3 using Hovatek mobile


Reply
#2
(05-10-2016, 12:33 PM)billa90 Wrote: If I charge the battery full and I leave it for few hours the battery will be dead and the phone is not even powering on again is there any help....?

Sent from my E3 using Hovatek mobile

I dont quite get what you're trying to say. Please, explain in detail
Reply
#3
What I'm trying to say is that the phone is dead and it is not recognized by pc when I try to flash it with stock rom

Sent from my E3 using Tapatalk
Reply
#4
(05-10-2016, 07:19 PM)billa90 Wrote: What I'm trying to say is that the phone is dead and it is not recognized by pc when I try to flash it with stock rom

Sent from my E3 using Tapatalk

Ok. Does the PC make a sound when you connect the phone?
Reply
#5
Yes the pc make sound but it will write USB not recognized and have try it on like 4 laptops it writing the same thing

Sent from my E3 using Hovatek mobile
Reply
#6
(05-13-2016, 09:16 AM)billa90 Wrote: Yes the pc make sound but it will write USB not recognized and have try it on like 4 laptops it writing the same thing

Sent from my E3 using Hovatek mobile

Try another USB cable
Reply
#7
Have try 5 different USB cable

Sent from my E3 using Tapatalk
Reply
#8
(This post was last modified: 05-13-2016, 01:28 PM by matybazz. )
(05-13-2016, 10:51 AM)billa90 Wrote: Have try 5 different USB cable

Sent from my E3 using Tapatalk

Ok do you have pdanet installed on your pc? If not download and install
you should also consider uninstalling and reinstalling you mediatek driver see https://forum.hovatek.com/thread-440.html
if still doesnt connect to flash then you should try using a different PC
Reply
#9
Have already use different pc with it

Sent from my E3 using Hovatek mobile
Reply
#10
But the still not working

Sent from my E3 using Hovatek mobile
Reply










Users browsing this thread:
1 Guest(s)