Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

TECNO G9 BATTERY NOT CHARGING

#1

My G9 Phone was infected with a virus so yesterday i tried to reset to factory settings. This caused the phone to get stuck in a boot loop. I then used the g9 stock rom from your site and sp flash tool to flash the phone. Everything worked as expected but as of today the device is no longer holding charge. I am charging it right now and its actually discharging right in front of me. I have re flashed the phone again just to be sure but no luck. Any help provided would be greatly appreciated


Reply
#2
(05-17-2016, 04:57 PM)stat1cshade Wrote: My G9 Phone was infected with a virus so yesterday i tried to reset to factory settings. This caused the phone to get stuck in a boot loop. I then used the g9 stock rom from your site and sp flash tool to flash the phone. Everything worked as expected but as of today the device is no longer holding charge. I am charging it right now and its actually discharging right in front of me. I have re flashed the phone again just to be sure but no luck. Any help provided would be greatly appreciated

From This guide https://forum.hovatek.com/thread-12741.html our firmware havebeen known to solve the issue check the charger or try another charger
Reply
#3
I used it flash G9 last night. It works like magic.

Sent from my Infinix-X552 using Hovatek mobile
Reply
#4
(05-18-2016, 09:09 AM)Banks Wrote: I used it flash G9 last night. It works like magic.

Sent from my Infinix-X552 using Hovatek mobile

Glad to hear that
Reply
#5
Thanks Guys i redownloaded the one in the thread and it seems to be working now

Reply










Users browsing this thread:
1 Guest(s)