Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

BROM ERROR: S_CHKSUM_ERROR (0x411) Smart PhoneFlash Tool error at the end of flashing

#1
Information 

I flash a rom for my THL 5000, I get it from NeedROM the VibeUI_1.5GB.
I load the scatter file from this folder, at the end of the firmware upgrade/ flash I get BROM ERROR S_CHKSUM_ERROR (0x411) I am not sure what this means and there are no links on it.
I have tried this with a previous ROM I scattered on my phone which did not work. So I don't believe the ROM is the issue.
I am wondering if it is the drivers on the laptop- if so then I don't know how to solve it as I have already installed them and changed them to others and the VCOM still works. So not sure.

When the DL and DA Check are unchecked in the options the software displays a green tick and says it was successful but the phone does not boot up.

Any idea what is happening

Also you will need to add this to the BROM ERROR Smart phone flash tool thread you have once you find a solution.

Harry



Attached Files
.png   BROM_Error.png (Size: 250.54 KB / Downloads: 21)
Reply
#2
I have sent an email to the hovertek support with the log files of the flash process, for some reason when I tried to attach them the were not permitted to be uploaded. If you do a search in the .log file, type in chksum_error and you will see a few instances of problems.
How else can I provide information to help?
Reply
#3
(07-20-2016, 02:04 PM)Harryortho Wrote: I flash a rom for my THL 5000, I get it from NeedROM the VibeUI_1.5GB.
I load the scatter file from this folder, at the end of the firmware upgrade/ flash I get BROM ERROR S_CHKSUM_ERROR (0x411) I am not sure what this means and there are no links on it.
I have tried this with a previous ROM I scattered on my phone which did not work. So I don't believe the ROM is the issue.
I am wondering if it is the drivers on the laptop- if so then I don't know how to solve it as I have already installed them and changed them to others and the VCOM still works. So not sure.

When the DL and DA Check are unchecked in the options the software displays a green tick and says it was successful but the phone does not boot up.

Any idea what is happening

Also you will need to add this to the BROM ERROR Smart phone flash tool thread you have once you find a solution.

Harry
Check your firmware folder and delete any checksum.ini file also make battery in the phone is charged
Reply
#4
(07-20-2016, 02:04 PM)Harryortho Wrote: I flash a rom for my THL 5000, I get it from NeedROM the VibeUI_1.5GB.
I load the scatter file from this folder, at the end of the firmware upgrade/ flash I get BROM ERROR S_CHKSUM_ERROR (0x411) I am not sure what this means and there are no links on it.
I have tried this with a previous ROM I scattered on my phone which did not work. So I don't believe the ROM is the issue.
I am wondering if it is the drivers on the laptop- if so then I don't know how to solve it as I have already installed them and changed them to others and the VCOM still works. So not sure.

When the DL and DA Check are unchecked in the options the software displays a green tick and says it was successful but the phone does not boot up.

Any idea what is happening

Also you will need to add this to the BROM ERROR Smart phone flash tool thread you have once you find a solution.

Harry

you need to untick da dl all with checksum then flash.
now, after flashing, is the phone totally dead or gets stuck at logo?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
Phone charged overnight
I previously tried to flash the old rom, I pressed the reset button, this then loaded the old rom but this often is met with acore process has unfortunately stopped. So that is not an option.
Also flashing with the boxes checked makes the error.
I pressed the button for reset, while the blue thl logo was on as I tried to do a download to that. As on the phone it is hard to know if the phone is on or off. On and off button did not work show much effect. I pressed the download while the phone was connected while the logo thl in blue letters against a black screen was displayed.

I am not sure if download/format +download or firmware upgrade is best, we will see.
I have done both since the errors.

I will try the same without the boxes ticked, I don't think it made a difference.
Also could not find a chksum.ini file in the scatter loading directory so I don't know why that would be an issue.
without the box ticked the process seemed to be a success
Blue thl logo upon turning on.... waiting... will wait max 5 minutes, if it has not passed this stage I don't really know what to do
Reply
#6
(07-22-2016, 09:53 AM)Ps. last step was done with firmware upgrade Harryortho Wrote: Phone charged overnight
I previously tried to flash the old rom, I pressed the reset button, this then loaded the old rom but this often is met with acore process has unfortunately stopped. So that is not an option.
Also flashing with the boxes checked makes the error.
I pressed the button for reset, while the blue thl logo was on as I tried to do a download to that. As on the phone it is hard to know if the phone is on or off. On and off button did not work show much effect. I pressed the download while the phone was connected while the logo thl in blue letters against a black screen was displayed.

I am not sure if download/format +download or firmware upgrade is best, we will see.
I have done both since the errors.

I will try the same without the boxes ticked, I don't think it made a difference.
Also could not find a chksum.ini file in the scatter loading directory so I don't know why that would be an issue.
without the box ticked the process seemed to be a success
Blue thl logo upon turning on.... waiting... will wait max 5 minutes, if it has not passed this stage I don't really know what to do
Reply
#7
ok phone is stuck at the logo, I will press the hard reset at the back of the phone to see if that makes a difference.
Nothing, just seems that the phone turns off.
turning phone on again.
logo appears blue thl with black background but nothing else.
I will try the process again with download+format but have to press the button on the rear for reset to make sure phone is off.
Ok did the reset, phone is flashing with the option i selected as mentioned (download + format), unless I need to do that to the original stock rom and then put this as a firmware upgrade.
Apparently successfull.
I am turning on my phone
blue thl logo against black background, time is 12.04 waiting....
I will do some work but my guess is the logo screen should not display for more than a few seconds or at most 3 minutes.
So far about 1 minute has passed by the time this message will be posted again
Reply
#8
still nothing, blue thl logo and black background.
http://www.needrom.com/download/thl-5000...2-0-final/
this is the rom with the scontained scatter file
http://www.needrom.com/download/rom-1-1-2-mod/
This is another stock version which I might try to see if this will work

Reply
#9
The updated official rom I have added with Format + Download, and it loads up with the blue thl against the white screen with the sound and animation , selecting reboot works... I put in the sim card, it says at the first instance there is a warning saying: Phone Storage is damaged, try reformatting it.
Phone says it has 0 bytes of storage available and 0bytes free.
I will now try and do the same thing with firmware upgrade with the other rom now.
Reply
#10
ok.
waiting...
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)