Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Solved] Replace Kingroot with SuperSU

#11

Ok... I have no idea what I did exactly, but finally it worked. I think the key is giving SuperSU time to work. After trying 3 or 4 times without any success, this time what I did(which might be what caused it to finally work) was that instead of rebooting when SuperSU failed to update binaries, I just canceled and left it like that. Few hours later I opened ES Explorer and realised that instead of asking root permission from Kingroot, it was instead asking it from SuperSU. So I granted the permission, opened SuperSU, updated binaries(this time binaries updated successfully), unistalled Kingroot, rebooted the tablet and Wallah... Kingroot is gone, root still intact and SuperSU working just fine. Now am a happy chap...
Thank You guys... 

.png   Screenshot_2016-08-21-17-28-37.png (Size: 101.56 KB / Downloads: 4)


Reply
#12
Oh and as a note, I updated the SuperSU (2.49) that was in the ZIP file with a newer SuperSU(2.76)...
Reply
#13
Ok. I replicated the procedure again and found out what I did right.
1. Before replacing Kingroot, make sure to reverse all granted root(to apps) by Kingroot. Best way is to unroot/uninstall Kingroot(using Kingroot's settings). Delete any remaining Kingroot associated folders.
2. Install Kingroot and root your device.
3. After rooting, when Kingroot asks you to optimize system, DO NOT optimize. Also Do not grant any apps root access.
4. If you have not downloaded SuperSU then head over to PlayStore and download latest version.
5. Also download the ZIP file from here
https://drive.google.com/open?id=0B9RniT...UJVS3dpd3c
(Thanx @Pline for link)
6. Follow these instructions(Thanx @Pline):
Quote:To replace kinguser with superuser u will need to extract mrw folder(from the above link) and move it into your internal storage.
In the mrw folder replace the superuser.apk file with the SuperSU(apk) file you downloaded from PlayStore and rename the SuperSU to superuser.apk.

Open Terminal emulator
and type: Su
Allow root permission

Type: sh /sdcard/mrw/root.sh
It might display some error, at the end it will launch supersu or open supersu manually. Update su binary normal. If update fails then wait for a minute or so and update again(Do Not Reboot). If success then you can reboot.
If fails 2nd time then Do Not Reboot, instead open any app(preferably ES Explorer) that requires root and check which root window appears. (i) If Kingroot window appears then go back Terminal and type the "sh /sdcard/mrw/root.sh" again and then try to update SuperSU binaries.
(ii) If SuperSU grant window opens then go back to SuperSU and update binaries 1 more time(it should be successful this time).
Now you can reboot.
Check root with a Root Checker(should show root by SuperSU/superuser, not kinguser).
If you still have Kingroot lingering around in your device, then you can safely remove it without losing root.
Reply










Users browsing this thread:
1 Guest(s)