Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Huawei G610 U20 can't flash SEC_RO file

#1

Hi, im wondering you can help with this issue.

I have a Huawei G610 U20 which has been in a bootloop.
I've tried countless times to flash it with the tools,
and stock ROMs provided by Huawei's official website.
I even watched your tutorials regarding using SP Flash Tool, but to no avail.

When I was running SP Flash Tool, I encountered the error 6126,
which was caused by SEC_RO.img file not being downloaded on to the phone. I've also tried using Rework-Secro file that came with the official ROM first, but still no luck.

I'm at the brink of losing hope at this point. Iv search every site on this matter but i couldn't find a breakthrough. On some sites they say it might be a hardware issue caused by a damaged EMMC chip on the phone, but i'm not sure it's true.

I used

Tool: SP_Flash_Tool_v3.1320.0.174_Secboot
ROM: G610-U20 V100R001C00B125CUSTC428D001_Firmware_countryValue_operatorValue_Android 4.2.1_EMUI 1.6_05021GHT

G610-U20_V100R001C00B121_Firmware_Egypt

G610-U20-V100R001C96B116 v_1C96



Attached Files
.jpg   Error 6126.JPG (Size: 88.43 KB / Downloads: 9)
Reply
#2
(This post was last modified: 08-22-2016, 02:11 PM by hovatek. )
(08-21-2016, 09:42 AM)greengoblin Wrote: Hi, im wondering you can help with this issue.

I have a Huawei G610 U20 which has been in a bootloop.
I've tried countless times to flash it with the tools,
and stock ROMs provided by Huawei's official website.
I even watched your tutorials regarding using SP Flash Tool, but to no avail.

When I was running SP Flash Tool, I encountered the error 6126,
which was caused by SEC_RO.img file not being downloaded on to the phone. I've also tried using Rework-Secro file that came with the official ROM first, but still no luck.

I'm at the brink of losing hope at this point. Iv search every site on this matter but i couldn't find a breakthrough. On some sites they say it might be a hardware issue caused by a damaged EMMC chip on the phone, but i'm not sure it's true.

I used

Tool: SP_Flash_Tool_v3.1320.0.174_Secboot
ROM: G610-U20 V100R001C00B125CUSTC428D001_Firmware_countryValue_operatorValue_Android 4.2.1_EMUI 1.6_05021GHT

G610-U20_V100R001C00B121_Firmware_Egypt

G610-U20-V100R001C96B116 v_1C96

Try using SP flash tool version 5 instead
Also, are you able to flash all other files apart from secro?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
(This post was last modified: 08-22-2016, 02:57 PM by greengoblin. )
Hi, thanks for the reply. Yes, all the other files install just fine. The error only comes on that particular secro file.

Let me try SP_tool version 5  and get back to you.
Reply
#4
(08-22-2016, 02:51 PM)greengoblin Wrote: Hi, thanks for the reply. Yes, all the other files install just fine. The error only comes on that particular secro file.

Let me try SP_tool version 5  and get back to you.

If you're able to flash other files then your phone should be able to boot up.
Have you tried a factory reset in recovery mode and emmc wipe in factory mode?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
(This post was last modified: 08-25-2016, 07:58 PM by greengoblin. )
(08-22-2016, 07:38 PM)hovatek Wrote:
(08-22-2016, 02:51 PM)greengoblin Wrote: Hi, thanks for the reply. Yes, all the other files install just fine. The error only comes on that particular secro file.

Let me try SP_tool version 5  and get back to you.

If you're able to flash other files then your phone should be able to boot up.
Have you tried a factory reset in recovery mode and emmc wipe in factory mode?

Hi again, Sorry for the late reply i had an unexpected trip at work that had me tied up and i just got back home today and wanted to see if i can pickup where we left off. I hope you can still help. 

I know right? i thought so myself if every file can download just fine except for Sec_ro and Preloader why shouldn't it work?

And YES the answer to your current question about factory reset: 

Sadly that was the first thing I tried doing when i got the phone. I booted to recovery mode (android system recovery <3e>) by Power Button + Volume UP and did:

1. wipe data/factory reset(it loaded with no errors nicely)

2. wipe cache partition(also no errors)

3. Reboot system now ( i get a " do_cust enter... " with error in the back ground)

its only after I apply "reboot system now" the second time is when the phone actually restarts. And its on to the boot loop again.

I even tried to get the UPDATE.APP on an SDCard and tried to access it via recovery mode through the "apply update from SDcard" option but to my surprise i couldn't see the UPDATE.APP file in the dload directory i created. I wasn't shown even though I was sure that it is there.

I know i was supposed to place it in the sdcard's root directory files but they weren't created for some reason. I'm thinking its that fact that the phone hasn't properly booted up and connected to my PC via mass storage that this had occurred.

Either way, I just got SP_Flash_Tool_v5.1612 like you requested earlier on and had tried downloading the same update ROM onto the phone but i'm getting an error each time i try to power the phone on when connected to the USB.

" BROM ERROR: S_BROM_DOWNLOAD_DA_FAIL(0x7D4) "

According to the list of errors you posted up on this link:
https://forum.hovatek.com/thread-439.html

I very sure its not my USB cord or that the phone battery has a problem or this wouldn't have happened while using the older SP_FLASH tool v3.1320.0.174_Secboot
I'm not sure if this is the most current SP_FLASH tool v5.1612 is most current though...

Attached Files
.jpg   SP_Flash_Tool_v5.1612 error.JPG (Size: 139.61 KB / Downloads: 5)
Reply
#6
(08-25-2016, 07:52 PM)greengoblin Wrote: .....
I very sure its not my USB cord or that the phone battery has a problem or this wouldn't have happened while using the older SP_FLASH tool v3.1320.0.174_Secboot
I'm not sure if this is the most current SP_FLASH tool v5.1612 is most current though...

Try the latest version of Sp flash tool @ https://forum.hovatek.com/thread-159.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)