Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] PLEASE HELP I NEED INFINIX HOT 3 TWRP RECOVERY

#1
(This post was last modified: 10-10-2016, 02:06 PM by Vicck. )

Device Specs:

Infinix X554 Hot 3 Variant 3 (X554-W90918-A2-L-20160607)
Chipset: MTK6580
OS Version: Android 5.1
Already rooted.

I have tried flashing a TWRP recovery using SP Flash tool, adb, Flashfire apk and Flashify apk but no success yet. I have also tried MTK Droid tools and Easy Magic TWRP Installer but I can't get TWRP to work on my phone. I have noticed though that whenever I flash TWRP and boot/reboot phone into recovery mode, it shows the Infinix logo, vibrates the shuts down and boots into the normal mode but the stock recovery still remains in the phone. Please help I really need TWRP. Here is a screenshot of my device info. Thanks

Edit: I have tried flashing a custom ROM made for the device (with TWRP in it) and got some white, black, red and green lines on booting phone but the device responded well with touch feedback and sound working properly. I tried flashing with stock preloader.bin and lk.bin but it got stuck on bootloop each time. The solution has always been flashing the stock ROM again. I'm not sure if it didn't work because the ROM might have been for a different Hot 3 variant.



Attached Files
.png   Screenshot_2016-10-10-15-50-54.png (Size: 80.16 KB / Downloads: 8)
Reply
#2
(10-10-2016, 01:51 PM)Vicck Wrote: Device Specs:

Infinix X554 Hot 3 Variant 3 (X554-W90918-A2-L-20160607)
Chipset: MTK6580
OS Version: Android 5.1
Already rooted.

I have tried flashing a TWRP recovery using SP Flash tool, adb, Flashfire apk and Flashify apk but no success yet. I have also tried MTK Droid tools and Easy Magic TWRP Installer but I can't get TWRP to work on my phone. I have noticed though that whenever I flash TWRP and boot/reboot phone into recovery mode, it shows the Infinix logo, vibrates the shuts down and boots into the normal mode but the stock recovery still remains in the phone. Please help I really need TWRP. Here is a screenshot of my device info. Thanks

Edit: I have tried flashing a custom ROM made for the device (with TWRP in it) and got some white, black, red and green lines on booting phone but the device responded well with touch feedback and sound working properly. I tried flashing with stock preloader.bin and lk.bin but it got stuck on bootloop each time. The solution has always been flashing the stock ROM again. I'm not sure if it didn't work because the ROM might have been for a different Hot 3 variant.

1. For the TWRP, where did you get that from?
2. For the custom ROM, there are multiple variants of the Hot 3. Try flashing boot, preloader and lk.bin then do a factory reset
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
Thanks for the reply.

1. I got the TWRP from this site: https://androidhq254.blogspot.com/2016/0...hot-3.html

2. You mean I should flash the stock boot.img, lk.bin and preloader.bin but the other components like the recovery should be from the custom ROM?
Can you guys help port a custom TWRP for me?
Reply
#4
(This post was last modified: 10-11-2016, 06:51 PM by hovatek. )
(10-11-2016, 12:55 PM)Vicck Wrote: Thanks for the reply.

1. I got the TWRP from this site: https://androidhq254.blogspot.com/2016/0...hot-3.html

2. You mean I should flash the stock boot.img, lk.bin and preloader.bin but the other components like the recovery should be from the custom ROM?
Can you guys help port a custom TWRP for me?

2. boot.img, lk.bin and preloader.bin from stock ; Yes
2b. Is this custom ROM in recovery or SP flash tool format?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
(10-11-2016, 06:50 PM)hovatek Wrote: 2. boot.img, lk.bin and preloader.bin  from stock ; Yes
2b. Is this custom ROM in recovery or SP flash tool format?

2b. It is in SP Flash Tool format. Here's the contents in the screenshot below.

Attached Files
.png   Untitled3.png (Size: 109.07 KB / Downloads: 6)
Reply
#6
(10-11-2016, 08:17 PM)Vicck Wrote: 2b. It is in SP Flash Tool format. Here's the contents in the screenshot below.

Flash back your stock then flash only boot and system from the custom ROM
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#7
(10-12-2016, 08:59 AM)hovatek Wrote: Flash back your stock then flash only boot and system from the custom ROM
What about the TWRP recovery. Should I flash it too?
Reply
#8
(10-12-2016, 04:10 PM)Vicck Wrote: What about the TWRP recovery. Should I flash it too?

You could flash that also
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#9
(This post was last modified: 10-13-2016, 04:45 PM by Vicck. )
(10-13-2016, 10:06 AM)hovatek Wrote: You could flash that also

I did everything you suggested. I flashed the stock ROM then flashed boot.img, recovery.img and system.img from custom ROM but still the phone went into a bootloop - starts, shows the Infinix logo then starts again and again and loops forever. I'm out of options. I just need TWRP to work.

Edit: I have actually done the reverse now. I flashed the custom ROM then flashed preloader.bin, lk.bin and boot.img from stock ROM and it worked except it was very unstable with many apps crashing and sd card not detected and I couldn't even boot/reboot into recovery. I'm back to the stock ROM.
Reply
#10
(10-13-2016, 03:23 PM)Vicck Wrote: I did everything you suggested. I flashed the stock ROM then flashed boot.img, recovery.img and system.img from custom ROM but still the phone went into a bootloop - starts, shows the Infinix logo then starts again and again and loops forever. I'm out of options. I just need TWRP to work.

Edit: I have actually done the reverse now. I flashed the custom ROM then flashed preloader.bin, lk.bin and boot.img from stock ROM and it worked except it was very unstable with many apps crashing and sd card not detected and I couldn't even boot/reboot into recovery. I'm back to the stock ROM.

Try flashing only preloader.bin and lk.bin from stock. Leave out boot.img
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)