Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Pls my Archos 50c neon [spreadtrum] is dead and won't show anything

#1
(This post was last modified: 10-11-2016, 10:55 AM by Jethro13. )

Archos 50c neon is dead unlikeafter MTK DEVICEs I know am to flash d preloader.bin file but this is a SPREADTRUM DEVICE I've not Idea on how to go about it! N this happen led after charging I switched it off but since three days now it refuses to power on but any time I connect to my computer via USB cable it recognizes it but d fone doesn't show anything, Pls ur help will be appreciated...


Reply
#2
(This post was last modified: 10-11-2016, 11:12 AM by hovatek. )
(10-11-2016, 08:11 AM)Jethro13 Wrote: Archos 50c neon is dead unlikeafter MTK DEVICEs I know am to flash d preloader.bin file but this is a SPREADTRUM DEVICE I've not Idea on how to go about it! N this happen led after charging I switched it off but since three days now it refuses to power on but any time I connect to my computer via USB cable it recognizes it but d fone doesn't show anything, Pls ur help will be appreciated...

Take out the battery for 30 seconds then reinsert.
connect it to your PC while holding the volume increase button
waiting....
Reply
#3
(10-11-2016, 11:07 AM)hovatek Wrote:
(10-11-2016, 08:11 AM)Jethro13 Wrote: Archos 50c neon is dead unlikeafter MTK DEVICEs I know am to flash d preloader.bin file but this is a SPREADTRUM DEVICE I've not Idea on how to go about it! N this happen led after charging I switched it off but since three days now it refuses to power on but any time I connect to my computer via USB cable it recognizes it but d fone doesn't show anything, Pls ur help will be appreciated...

Take out the battery for 30 seconds then reinsert.
connect it to your PC while holding the volume increase button
waiting....
Did just that nothing happened
Reply
#4
(10-11-2016, 11:28 AM)Jethro13 Wrote: Did just that nothing happened

Ok.
Do you have the firmware for this phone?
Reply
#5
(10-11-2016, 06:32 PM)hovatek Wrote:
(10-11-2016, 11:28 AM)Jethro13 Wrote: Did just that nothing happened

Ok.
Do you have the firmware for this phone?
I only have the tcard firmware unfortunately that's what D official website for Archos had not pc
Reply
#6
(10-11-2016, 06:45 PM)Jethro13 Wrote: I only have the tcard firmware unfortunately that's what D official website for Archos had not pc

Hmm.
Ok. lets run a test.
Open Device manager then connect the phone?
1. What does the phone get detected as?
2. Does it make a connection-disconnection sound?
Reply
#7
(10-12-2016, 08:53 AM)hovatek Wrote:
(10-11-2016, 06:45 PM)Jethro13 Wrote: I only have the tcard firmware unfortunately that's what D official website for Archos had not pc

Hmm.
Ok. lets run a test.
Open Device manager then connect the phone?
1. What does the phone get detected as?
2. Does it make a connection-disconnection sound?

Yes it does the connection sound is thr every time I connect it..
Reply
#8
(This post was last modified: 10-14-2016, 11:50 AM by hovatek. )
(10-13-2016, 04:50 PM)Jethro13 Wrote: Yes it does the connection sound is thr every time I connect it..

Ok. I'll assume the battery is good and well charged
You'll need a pac file or a working phone of the same model to revive your phone.
Do you have either?
Reply
#9
(10-14-2016, 11:36 AM)hovatek Wrote:
(10-13-2016, 04:50 PM)Jethro13 Wrote: Yes it does the connection sound is thr every time I connect it..

Ok. I'll assume the battery is good and well charged
You'll need a pac file or a working phone of the same model to revive your phone.
Do you have either?
I don't have a working fine of the same model....
Reply
#10
(10-20-2016, 06:53 PM)Jethro13 Wrote: I don't have a working fine of the same model....
since the PC still recognizes the phone, there's hope.
you'll need to search online for the pac file (assuming its not a hardware issue) or someone with the same phone
Reply










Users browsing this thread:
1 Guest(s)