Hi, Guest! Login / Register




Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Downloads] Collection of MTK Droid Tool versions

#1
(This post was last modified: 07-07-2017, 02:19 AM by hovatek. )

MTK Droid tools is a Windows tool used to backup Mediatek Android phones and create custom recoveries.

[Image: 1.jpg]

Tutorials on MTK Droid tools



Download MTK Droid Tool versions





Reply
#2
(This post was last modified: 10-25-2016, 06:59 AM by .... )
The link for 2.5.3 and 2.5.2 (and probably others) is not working for me.
Edit: Nvm works on chrome. Sorry.
Reply
#3
This tool  seems doesnot work anymore
Reply
#4
(This post was last modified: 01-05-2017, 09:35 AM by hovatek. )
(01-04-2017, 03:55 PM)lymo Wrote: This tool  seems doesnot work anymore

Yes, 2.5 doesn't work for newer models
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
(01-05-2017, 09:21 AM)hovatek Wrote:
(01-04-2017, 03:55 PM)lymo Wrote: This tool  seems doesnot work anymore

Yes, 2.5 doesn't work for newer models

i have p 5once i used this tool and working but now when i connect seems loading and after time tool not responding
Reply
#6
(01-05-2017, 05:22 PM)lymo Wrote: i have p 5once i used this tool and working but now when i connect seems loading and after time tool not responding

create a new thread so we focus on it.
see https://forum.hovatek.com/thread-514.html for how to create a thread
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#7
(01-05-2017, 09:21 AM)hovatek Wrote:
(01-04-2017, 03:55 PM)lymo Wrote: This tool  seems doesnot work anymore

Yes, 2.5 doesn't work for newer models

Please if 2.5 doesn't work for newer version , would the 2.3 and 2.4 work for newer model phones like 5.1 and 6.0 ?
Reply
#8
(01-26-2017, 10:11 AM)ALBA Wrote: Please if 2.5 doesn't work for newer version , would the 2.3 and 2.4 work for newer model phones like 5.1 and 6.0 ?

No

Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#9
(01-26-2017, 10:11 AM)ALBA Wrote:
(01-05-2017, 09:21 AM)hovatek Wrote:
(01-04-2017, 03:55 PM)lymo Wrote: This tool  seems doesnot work anymore

Yes, 2.5 doesn't work for newer models

Please if 2.5 doesn't work for newer version , would the 2.3 and 2.4 work for newer model phones like 5.1 and 6.0 ?
Reply
#10
(01-05-2017, 09:21 AM)hovatek Wrote:
(01-04-2017, 03:55 PM)lymo Wrote: This tool  seems doesnot work anymore

Yes, 2.5 doesn't work for newer models

What works for 4.4.2 ICS ?
Reply










Users browsing this thread:
1 Guest(s)