Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

My tecnop9 is not starting up

#1

Hello, I have a tecnop9 I have been using for a while now, about two days ago. I switched it off to charge for awhile after I put it back on, it began hanging and restarting itself until it went off since then &I have not being able to put it back on. I don't know if I can get any assistance with it from you because this is the first time I am having this type of issues with it. The only issues I have had with this phone is the charging port which I have fixed.


Reply
#2
(10-24-2016, 06:33 PM)temilorun herry Wrote: Hello, I have a tecnop9 I have been using for a while now, about two days ago. I switched it off to charge for awhile after I put it back on, it began hanging and restarting itself until it went off since then &I have not being able to put it back on. I don't know if I can get any assistance with it from you because this is the first time I am having this type of issues with it. The only issues I have had with this phone is the charging port which I have fixed.

Does your PC make a sound when you connect the phone?
Need further assistance? Speak with a Hovatek Representative:

Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)

Request for Private Support
* Install the Hovatek Forum app
* Listen to H-Tech Radio
* Helpline: +2348021840309
* Email: technical@hovatek.com
* Skype: Hovatek
Reply










Users browsing this thread:
1 Guest(s)