Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

MY INFINIX X551 DEAD FLASH WITH X551 STOCK ROM STILL NOT ON

#1

Good morning Hovatek, i will be glad if you can help me out on this. it all happen on 1st of this year while i'm playing music with my phone and just fall down on my hand a little and the phone went off and like that and i'm trying to on it since then not turning on and still not charge when i put it on charge. I collect it with my system(pc) and discover that it's giving the connecting sound so i download stock firmware and load it with sp flash tools and it's load fine but still not on and still not charge and even wondering maybe it's the firmware but have download almost three stock rom of different version of 4.4 and 5.1 but still not working but the file load successful. I'm in total confusion now cos i don't know exactly where the problem may come from and will be so glad if you can help me out on this. thanks.


Reply
#2
I think thats a hardware issue,cos i have experienced that with infinix Hot,flashed it successfully too, and uptil now its still dead cos no engineer could wake it up.
Reply
#3
(01-04-2017, 10:22 AM)kola092 Wrote: Good morning Hovatek, i will be glad if you can help me out on this. it all happen on 1st of this year while i'm playing music with my phone and just fall down on my hand a little and the phone went off and like that and i'm trying to on it since then not turning on and still not charge when i put it on charge. I collect it with my system(pc) and discover that it's giving the connecting sound so i download stock firmware and load it with sp flash tools and it's load fine but still not on and still not charge and even wondering maybe it's the firmware but have download almost three stock rom of different version of 4.4 and 5.1 but still not working but the file load successful. I'm in total confusion now cos i don't know exactly where the problem may come from and will be so glad if you can help me out on this. thanks.
It maybe the hardware us @Alvincutie side above... please kindly take it to phone repair
Reply
#4
Bring it I can fixed it

Sent from my TECNO F7 using Hovatek mobile
Reply










Users browsing this thread:
1 Guest(s)