Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Unbrick Tecno W4 then Root It

#1

Good day, I'm very new here, please pardon me if I'm breaking any rules.
I just got the tecno w4 with build number W4-AW875A1-M-161010v10
I tried to root it by following a guide I saw online but I bricked it along the way.
I was able to then flash it with ROM W4-AW875A-A1-M-20160603 with sp flash tool.
I flashed till the end where it said Download ok but the phone never came one, it was like it was still bricked.
Now when i try to reflash using the same ROM W4-AW875A-A1-M-20160603, it gives me error BROM ERROR: S_FT_ENABLE_DRAM_FAIL (0xFC0)
I've read a few posts online, turns out that ROM W4-AW875A-A1-M-20160603 wasn't compatible with my particular version.
is it possible someone provide me with ROM W4-AW875A1-M-161010v10 so I can flash my phone using sp flash tool?

And if I'm successful in bringing the phone back to life, how do I root it?

Cheers.


Reply
#2
(This post was last modified: 01-12-2017, 11:04 AM by hovatek. )
(01-11-2017, 05:50 PM)edgamestar Wrote: Good day, I'm very new here, please pardon me if I'm breaking any rules.
I just got the tecno w4 with build number W4-AW875A1-M-161010v10
I tried to root it by following a guide I saw online but I bricked it along the way.
I was able to then flash it with ROM W4-AW875A-A1-M-20160603 with sp flash tool.
I flashed till the end where it said Download ok but the phone never came one, it was like it was still bricked.
Now when i try to reflash using the same ROM W4-AW875A-A1-M-20160603, it gives me error BROM ERROR: S_FT_ENABLE_DRAM_FAIL (0xFC0)
I've read a few posts online, turns out that ROM W4-AW875A-A1-M-20160603 wasn't compatible with my particular version.
is it possible someone provide me with ROM W4-AW875A1-M-161010v10 so I can flash my phone using sp flash tool?

And if I'm successful in bringing the phone back to life, how do I root it?

Cheers.

That error is a compatibility error (refer to https://forum.hovatek.com/thread-439.html ) . The error might've interrupted flashing and caused the phone to go dead. To revive it, follow the guide @ https://forum.hovatek.com/thread-808.html
Now, during your first rooting attempt, what exactly went wrong and in what way was the phone bricked (how was it behaving)?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
(01-12-2017, 10:59 AM)hovatek Wrote:
(01-11-2017, 05:50 PM)edgamestar Wrote: Good day, I'm very new here, please pardon me if I'm breaking any rules.
I just got the tecno w4 with build number W4-AW875A1-M-161010v10
I tried to root it by following a guide I saw online but I bricked it along the way.
I was able to then flash it with ROM W4-AW875A-A1-M-20160603 with sp flash tool.
I flashed till the end where it said Download ok but the phone never came one, it was like it was still bricked.
Now when i try to reflash using the same ROM W4-AW875A-A1-M-20160603, it gives me error BROM ERROR: S_FT_ENABLE_DRAM_FAIL (0xFC0)
I've read a few posts online, turns out that ROM W4-AW875A-A1-M-20160603 wasn't compatible with my particular version.
is it possible someone provide me with ROM W4-AW875A1-M-161010v10 so I can flash my phone using sp flash tool?

And if I'm successful in bringing the phone back to life, how do I root it?

Cheers.

That error is a compatibility error (refer to https://forum.hovatek.com/thread-439.html ) . The error might've interrupted flashing and caused the phone to go dead. To revive it, follow the guide @ https://forum.hovatek.com/thread-808.html
Now, during your first rooting attempt, what exactly went wrong and in what way was the phone bricked (how was it behaving)?

At first I tried flashing twrp 3.0 recovery on it to enable me install SuperSU but it didn't detect the phone and upon pulling out it didn't boot.
So I dismantled it and removed the battery
Then I flashed W4-AW875A-A1-M-20160603 on it thinking it didn't detect cos of the stock ROM on it.
It flashed the W4-AW875A-A1-M-20160603 ROM successfully but when I try to turn on, no response again.
Then I tried to reflash W4-AW875A-A1-M-20160603 then started to get BROM ERROR: S_FT_ENABLE_DRAM_FAIL (0xFC0).

So now I figured I'd need W4-AW875A1-M-161010v10

Fortunately for me my neighbor uses same phone and his ROM is W4-AW875A1-M-161010v10 so I backed up his ROM without userdata Using miracle box.

I'm sacred to flash the phone with this back up ROM .
Should i go ahead?
Reply
#4
(This post was last modified: 01-12-2017, 05:32 PM by edgamestar. )
I just tried flashing it with the back up ROM using sp flash tool
Upon loading the scatter file I get this error s_dl_load_region_is_overlap please check partition size
Then when I click download and try to flash I get BROM ERROR: S_DL_GET_DRAM_SETTING_FAIL EIM: Obtain DRAM Failed
Reply
#5
(This post was last modified: 01-12-2017, 08:50 PM by edgamestar. )
Trying to flash with miracle box
It just crashes every time it detects the phone
See attachment

Attached Files
.png   Screenshot (15).png (Size: 259.97 KB / Downloads: 4)
Reply
#6
(01-12-2017, 02:12 PM)edgamestar Wrote: At first I tried flashing twrp 3.0 recovery on it to enable me install SuperSU but it didn't detect the phone and upon pulling out it didn't boot.
So I dismantled it and removed the battery
Then I flashed W4-AW875A-A1-M-20160603 on it thinking it didn't detect cos of the stock ROM on it.
It flashed the W4-AW875A-A1-M-20160603 ROM successfully but when I try to turn on, no response again.
Then I tried to reflash W4-AW875A-A1-M-20160603 then started to get BROM ERROR: S_FT_ENABLE_DRAM_FAIL (0xFC0).

So now I figured I'd need W4-AW875A1-M-161010v10

Fortunately for me my neighbor uses same phone and his ROM is W4-AW875A1-M-161010v10 so I backed up his ROM without userdata Using miracle box.

I'm sacred to flash the phone with this back up ROM .
Should i go ahead?

Why not flash the backup using Miracle Box @ https://forum.hovatek.com/thread-14106.html ?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#7
(01-12-2017, 08:49 PM)edgamestar Wrote: Trying to flash with miracle box
It just crashes every time it detects the phone
See attachment

Try using a different port & PC
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#8
(01-12-2017, 08:56 PM)hovatek Wrote:
(01-12-2017, 08:49 PM)edgamestar Wrote: Trying to flash with miracle box
It just crashes every time it detects the phone
See attachment

Try using a different port & PC

Ok
Let me try that.
I hope it works
I'll use a windows 8 PC to try it

Reply
#9
I just tried with a windows 7 PC
miracle box gave an error BootData ERR(2): O_O
Reply
#10
(This post was last modified: 01-13-2017, 09:39 AM by hovatek. )
(01-12-2017, 09:21 PM)edgamestar Wrote: I just tried with a windows 7 PC
miracle box gave an error BootData ERR(2): O_O

Retry flashing
Hope the phone is powered off with battery inside?
waiting...
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)