Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Tecno M3 (Old) Stuck at Boot Logo

#1

I have A Tecno M3 with me, (the one with Blue Background) it was having stability issues as it goes on and off, at times, would just to to Recovery Mode by itself, So I decided to flash it. I initially flashed it with 4.4 ROM (the one that boots with Smart Experience stuff) It got stuck at Boot Logo. I later downloaded the old stock ROM from here for the same model of the phone (Tecno M3)
The phone is still stuck at the Boot Logo.
I've tried the 'Wipe Data/Factory Reset' option from the recovery mode, but it gives this Error Mounting Data.
What can one do to bring the phone back to life?


Reply
#2
(01-29-2017, 05:20 PM)wilfem Wrote: I have A Tecno M3 with me, (the one with Blue Background) it was having stability issues as it goes on and off, at times, would just to to Recovery Mode by itself, So I decided to flash it. I initially flashed it with 4.4 ROM (the one that boots with Smart Experience stuff) It got stuck at Boot Logo. I later downloaded the old stock ROM from here for the same model of the phone (Tecno M3)
The phone is still stuck at the Boot Logo.
I've tried the 'Wipe Data/Factory Reset' option from the recovery mode, but it gives this Error Mounting Data.
What can one do to bring the phone back to life?

Fix the mount /data error using https://forum.hovatek.com/thread-580.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)