Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Help on tecno l8 plus.

#1

Hello here... Good day!
Help on my tecno l8 plus. The phone went off for months now, and I've tried different methods, all to no avail.

I downloaded different Firmwares, each of at least 900mb, with Miracle loader embedded in the rar files.

The problem is that the phone isn't detected whenever I connect it with to the system.
I already installed the VCOM drivers successfully.
I need your help here please!
Thanks in advance!


Reply
#2
Hope your system do see your phone when switch off, If not mean the driver is not completed,:: Download the stock rom from the site, extract it, then use S p flashing tools. After open flashing tools you will see the sign of your phone click on the scatter file of the stock you just download, it will bring d details of the phone, then remove the cable from your phone and then click on download, then insert the cable back, wait for Some minute's, it will pop out itself. After mark it as completed then remove it and reboot it. Hope to hear from you soon with Good news

Sent from my Infinix NOTE 3 using the Hovatek Forum App
Reply
#3
(04-27-2017, 03:52 AM)Cleverboi Wrote: Hello here... Good day!
Help on my tecno l8 plus. The phone went off for months now, and I've tried different methods, all to no avail.

I downloaded different Firmwares, each of at least 900mb, with Miracle loader embedded in the rar files.

The problem is that the phone isn't detected whenever I connect it with to the system.
I already installed the VCOM drivers successfully.
I need your help here please!
Thanks in advance!

Does your PC make a sound when you connect the phone?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#4
(04-27-2017, 10:08 AM)hovatek Wrote:
(04-27-2017, 03:52 AM)Cleverboi Wrote: Hello here... Good day!
Help on my tecno l8 plus. The phone went off for months now, and I've tried different methods, all to no avail.

I downloaded different Firmwares, each of at least 900mb, with Miracle loader embedded in the rar files.

The problem is that the phone isn't detected whenever I connect it with to the system.
I already installed the VCOM drivers successfully.
I need your help here please!
Thanks in advance!

Does your PC make a sound when you connect the phone?

Yes, it does make sounds. But it doesn't connect.
I used both spfalsh tool and miracle. It doesn't connect, but just continue making sounds.
Note: The phone is totally dead (doesn't show any sign of charging)

Sent from my TECNO H5 using the Hovatek Forum App
Reply
#5
(04-27-2017, 08:55 AM)sunisky Wrote: Hope your system do see your phone when switch off, If not mean the driver is not completed,:: Download the stock rom from the site, extract it, then use S p flashing tools. After open flashing tools you will see the sign of your phone click on the scatter file of the stock you just download, it will bring d details of the phone, then remove the cable from your phone and then click on download, then insert the cable back, wait for Some minute's, it will pop out itself. After mark it as completed then remove it and reboot it. Hope to hear from you soon with Good news

Sent from my Infinix NOTE 3 using the Hovatek Forum App

I already tried this... Seems the vCOM drivers ain't complete or something is wrong.
The firmware was in bin format, so I had to use miracle but the system doesn't recognize the device at all because the phone is totally dead with no sign of life!

Sent from my TECNO H5 using the Hovatek Forum App
Reply
#6
Use flash tool box

Sent from my Infinix NOTE 3 using the Hovatek Forum App
Reply
#7
I mean use S P flashing tools to do so,
It doesn't matter it show since you said it's dead,
Just know If it sound when you plug your phone to d system. If it do Then you are Good to go. Download the zip file of the stock rom, extract, and do as before described

Sent from my Infinix NOTE 3 using the Hovatek Forum App
Reply
#8
(04-27-2017, 11:17 AM)Cleverboi Wrote: Yes, it does make sounds. But it doesn't connect.
I used both spfalsh tool and miracle. It doesn't connect, but just continue making sounds.
Note: The phone is totally dead (doesn't show any sign of charging)

Sent from my TECNO H5 using the Hovatek Forum App

I believe it's making a connection-disconnection sound. Does it make both continuously?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#9
(04-27-2017, 03:24 PM)hovatek Wrote:
(04-27-2017, 11:17 AM)Cleverboi Wrote: Yes, it does make sounds. But it doesn't connect.
I used both spfalsh tool and miracle. It doesn't connect, but just continue making sounds.
Note: The phone is totally dead (doesn't show any sign of charging)

Sent from my TECNO H5 using the Hovatek Forum App

I believe it's making a connection-disconnection sound. Does it make both continuously?

Exactly, that's what happens.

Sent from my TECNO H5 using the Hovatek Forum App
Reply
#10
(04-27-2017, 11:55 AM)sunisky Wrote: I mean use S P flashing tools to do so,
It doesn't matter it show since you said it's dead,
Just know If it sound when you plug your phone to d system. If it do Then you are Good to go. Download the zip file of the stock rom, extract, and do as before described

Sent from my Infinix NOTE 3 using the Hovatek Forum App

No zip file available, I searched Google.

Also, I think its not firmware error. The error should be either VCOM drivers or because the phone is dead.

Sent from my TECNO H5 using the Hovatek Forum App
Reply










Users browsing this thread:
1 Guest(s)