Hi, Guest! Login / Register




Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Development] How to root the Tecno Camon CX

#21

(07-20-2017, 02:38 PM)ajben10 Wrote: After installing twrp using fastboot boot recovery.img, twrp is installed tried to install super su.zip but couldn't find the phone memory so I decided to reboot so I can move the super su.zip to external sd, on rebooting my phone is stuck on that TECNO PAGE, showing

Orange state
Your device has been unlocked and can't be trusted
Your device will boot in 5 seconds

But it doesn't come up, it's just stuck there

Copy SuperSU to external SD card > Boot the phone into recovery > If still stock recovery, select the option to go to Bootloader > repeat the recovery.img boot process then flash Supersu from sd card
Let me know how it goes


Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#22
If you don't have a SD can't
Enter stock recovery and reboot to bootloader
Copy The SuperSU zip to adb folder and rename it to su.zip
Then
"fastboot boot recovery.img"
after booting TWRP,go to advanced and choose adb sideload and then type
"adb devices"
If you have installed the driver properly you should see
"xxx sideload"
And then
”adb sideload su.zip"
Reboot!

Sent from my TECNO Camon CX using Hovatek mobile
Reply
#23
(This post was last modified: 09-07-2017, 09:14 AM by abiodun.ajibola. )
please help me here.

i want to believe the full backup is paramount to getting the camon cx correctly rooted, but during the backup keeps failing saying "failed" when backing up system image.

and am not even sure if the UPDATE-SuperSU-v2.76-20160630161323 install correctly too. even though my phone boot up normally, checking with root checker says its not yet rooted.

also during the installing of the supersu i got this.

checking patch status
already patched attemtpting to fin stock backup
stock restore failed. attemtpting ramdisk restore
ramdisk backuo restored (oTA impossible)

the stock restore failed....is this normal??


pls help here
Reply
#24
(09-07-2017, 08:31 AM)abiodun.ajibola Wrote: please help me here.

i want to believe the full backup is paramount to getting the camon cx correctly rooted, but during the backup keeps failing saying "failed" when backing up system image.

and am not even sure if the UPDATE-SuperSU-v2.76-20160630161323 install correctly too. even though my phone boot up normally, checking with root checker says its not yet rooted.

also during the installing of the supersu i got this.

checking patch status
already patched attemtpting to fin stock backup
stock restore failed. attemtpting ramdisk restore
ramdisk backuo restored (oTA impossible)

the stock restore failed....is this normal??


pls help here

It is failing to back may be because you included a partition "system image " am not sure of the name but its the largest partition close to 4G. If you exclude this it should be able to finish.

Sent from my TECNO Camon CX using Hovatek Forum
Reply
#25
(This post was last modified: 09-07-2017, 05:32 PM by hovatek. )
(09-07-2017, 08:31 AM)abiodun.ajibola Wrote: please help me here.

i want to believe the full backup is paramount to getting the camon cx correctly rooted, but during the backup keeps failing saying "failed" when backing up system image.

and am not even sure if the UPDATE-SuperSU-v2.76-20160630161323 install correctly too. even though my phone boot up normally, checking with root checker says its not yet rooted.

also during the installing of the supersu i got this.

checking patch status
already patched attemtpting to fin stock backup
stock restore failed. attemtpting ramdisk restore
ramdisk backuo restored (oTA impossible)

the stock restore failed....is this normal??


pls help here

If you're using Miracle Box 2.27A then its very unlikely to work, unless you're using a box and higher version.
Are you certain the phone booted into Philz recovery and not stock recovery when flashing the supersu?

Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#26

Hello bro
I have thé same problem with my Cx.Any solution ???tahnks
Reply
#27
(09-27-2017, 01:58 AM)meconexion Wrote: Hello bro
I have thé same problem with my Cx.Any solution ???tahnks

What problem exactly are you having?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#28
please help oooooo. have followed the process to unlock the bootloader but after i entered the command 'fastboot oem unlock' a prompt came up and i press the volume up botton for yes. all i see after this SELECT BOOT MODE with an arrow pointing at FASTBOOT. so i decided to proceed by entering the next command since i didnt see any message with the word SUCCESS. but after i input the last command FASTBOOT REBOOT it then says waiting for device. that is all i keep seing oooo and my phone only shows SELECT BOOT MODE and i was unabe to operate it. please i need your help
Reply
#29
please help oooooo. have followed the process to unlock the bootloader but after i entered the command 'fastboot oem unlock' a prompt came up and i press the volume up botton for yes. all i see after this SELECT BOOT MODE with an arrow pointing at FASTBOOT. so i decided to proceed by entering the next command since i didnt see any message with the word SUCCESS. but after i input the last command FASTBOOT REBOOT it then says waiting for device. that is all i keep seing oooo and my phone only shows SELECT BOOT MODE and i was unabe to operate it. please i need your help
Reply
#30
(10-03-2017, 05:58 PM)majekwahab Wrote: please help oooooo. have followed the process to unlock the bootloader but after i entered the command 'fastboot oem unlock' a prompt came up and i press the volume up botton for yes. all i see after this SELECT BOOT MODE with an arrow pointing at FASTBOOT. so i decided to proceed by entering the next command since i didnt see any message with the word SUCCESS. but after i input the last command FASTBOOT REBOOT it then says waiting for device. that is all i keep seing oooo and my phone only shows SELECT BOOT MODE and i was unabe to operate it. please i need your help

Hold the power button till it reboots
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
2 Guest(s)