Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] hard bricked samsung galaxy grand prime(sm-g530h)..black screen ..no BL no recovery

#1
Lightbulb  (This post was last modified: 06-28-2017, 05:11 PM by flintchez52. )

been a while hova active 
my greetings to you all once again 

....please i need your help 
i hard brick my samsung galaxy grand prime(sm-g530h)
by mistakenly loading an mtk 6572 rom through sp flash tools
thought its a clone of the original 
but i was wrong
cause its a friend phone 
and i cant get in to download mode nor recovery mode 
it doesnt  even show the samsung grand prime logo 
just bright black screen 
and nothing else 
i tried using odin 
but it would disconnet every 3second 
even when i tried to flash pit and boot loader
it wont let me cause its 3seconds before it goes off and on again
i tried usb download mode jig it didnt work
i tried flashing bootable unbrick.img to an sd card it also didnt work
watched a couple of videos on youtube 
still didnt help 
please hovatek i need your help 
please 
thanks in advance


Reply
#2
(This post was last modified: 06-28-2017, 11:44 PM by hovatek. )
(06-28-2017, 05:09 PM)flintchez52 Wrote: been a while hova active 
my greetings to you all once again 

....please i need your help 
i hard brick my samsung galaxy grand prime(sm-g530h)
by mistakenly loading an mtk 6572 rom through sp flash tools
thought its a clone of the original 
but i was wrong
cause its a friend phone 
and i cant get in to download mode nor recovery mode 
it doesnt  even show the samsung grand prime logo 
just bright black screen 
and nothing else 
i tried using odin 
but it would disconnet every 3second 
even when i tried to flash pit and boot loader
it wont let me cause its 3seconds before it goes off and on again
i tried usb download mode jig it didnt work
i tried flashing bootable unbrick.img to an sd card it also didnt work
watched a couple of videos on youtube 
still didnt help 
please hovatek i need your help 
please 
thanks in advance

I want to emphasize "by mistakenly loading an mtk 6572 rom through sp flash tools"
This can only mean the phone is a clone (Mediatek) and Odin is not the right tool.
You first need to find the right firmware and flash using SP flash tool.
Check https://hovatek.com/redirect.php?link=ht...lash-file/
1. Does the PC still make a sound when you connect the phone?
2. Was flashing of the first MT6572 ROM complete or it got interrupted by an error
Reply
#3
First this is a clone
I assume the phone have a working preloader
Read info using miracle box so we can know the mtk chipset it uses then find the correct rom online

Sent from my TECNO Camon CX using Hovatek mobile
Reply
#4
thank you
for your replies
its an MTK 6572 phone
so I eventually found its a clone from the major Chinese alps cloners
but I saw a list of random roms of up to 15 for it
but I tried only two and it didnt work
hopefully one would work out of the 15 random rom
...thank you hovatek
....yours ever
...flint
Reply










Users browsing this thread:
1 Guest(s)