Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Acer Liquid Jade won't boot, vibrates indefinitely

#1

Hi,

I have a Acer Liquid Jade S55. Tried flashing it using SP Flash Tool 5.1416.00 (which I have done couple of times earlier). After trying "Download only" option with excluding preloader tried to boot the phone but it stuck on Acer logo for more than 20 minutes. Turned off the phone, started SP Flash Tool once again and selected "Firmware upgrade" (as I saw it was suggested on xda-developers forum if "Download only" is not enough). After completing the process, I tried to boot the phone but the screen remains off and the phone keeps vibrating every 15-20 seconds. Tried flashing with different versions of firmware and SP Flash Tool after that (sometimes preloader only, than everything else), but it remains the same. Connecting to wall charger/laptop provokes same behavior (vibrating indefinitely). Not sure at the moment, but I think the battery level was relatively low when I first tried flashing process.

Does anyone know what can I do in order to fix this?

I've seen suggestions to keep phone on charger for couple of hours (or even days) until it displays it's charging but it keeps vibrating when I connect it on charger. Or even remove the battery and than start charging (which might not be possible as I think there is non-removable battery inside this phone).


Reply
#2
(This post was last modified: 07-01-2017, 05:48 PM by hovatek. )
(07-01-2017, 01:08 PM)МиливојКовачевић Wrote: Hi,

I have a Acer Liquid Jade S55. Tried flashing it using SP Flash Tool 5.1416.00 (which I have done couple of times earlier). After trying "Download only" option with excluding preloader tried to boot the phone but it stuck on Acer logo for more than 20 minutes. Turned off the phone, started SP Flash Tool once again and selected "Firmware upgrade" (as I saw it was suggested on xda-developers forum if "Download only" is not enough). After completing the process, I tried to boot the phone but the screen remains off and the phone keeps vibrating every 15-20 seconds. Tried flashing with different versions of firmware and SP Flash Tool after that (sometimes preloader only, than everything else), but it remains the same. Connecting to wall charger/laptop provokes same behavior (vibrating indefinitely). Not sure at the moment, but I think the battery level was relatively low when I first tried flashing process.

Does anyone know what can I do in order to fix this?

I've seen suggestions to keep phone on charger for couple of hours (or even days) until it displays it's charging but it keeps vibrating when I connect it on charger. Or even remove the battery and than start charging (which might not be possible as I think there is non-removable battery inside this phone).

This might be a combination of incompatible preloader + drained battery (could also be just one of either two). This could mean the device is trying to boot up but doesn't have enough power to. You could try yet another firmware if you can get one or just leave it connected to power. It might keep vibrating at intervals but will eventually retain enough charge to boot up.
You could also hold the power button for some seconds when connected to power to force a charge
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
Already tried 3 different firmware versions. Kept it connected to my laptop overnight, but nothing's changed. I will leave it connected to wall charger until it gets enough power and hope for the best.
Reply
#4
(07-01-2017, 07:17 PM)МиливојКовачевић Wrote: Already tried 3 different firmware versions. Kept it connected to my laptop overnight, but nothing's changed. I will leave it connected to wall charger until it gets enough power and hope for the best.

Keep us posted
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
Day six. Still connected to charger. Every once in a while trying to force charge by keeping power button pressed for couple of restart cycles (periodically vibrating), sometimes trying combination of volume up + power button, but still no changes. Not sure if it should remain on charger for some more time, or should I try to flash it with another firmware version and put it back on charger?  Undecided
Reply
#6
(07-07-2017, 01:12 PM)МиливојКовачевић Wrote: Day six. Still connected to charger. Every once in a while trying to force charge by keeping power button pressed for couple of restart cycles (periodically vibrating), sometimes trying combination of volume up + power button, but still no changes. Not sure if it should remain on charger for some more time, or should I try to flash it with another firmware version and put it back on charger?  Undecided

Stop charging it. Try another firmware if you can.
BTW, is the battery inbuilt or removable?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#7
(07-08-2017, 10:56 AM)hovatek Wrote:
(07-07-2017, 01:12 PM)МиливојКовачевић Wrote: Day six. Still connected to charger. Every once in a while trying to force charge by keeping power button pressed for couple of restart cycles (periodically vibrating), sometimes trying combination of volume up + power button, but still no changes. Not sure if it should remain on charger for some more time, or should I try to flash it with another firmware version and put it back on charger?  Undecided

Stop charging it. Try another firmware if you can.
BTW, is the battery inbuilt or removable?

It' not removable. Or at least not if I don't open it somehow, but the only screw which should be unscrewed to open it is somehow stuck. 
So what's the best option to use now, if I'm going to flash it with SP Flash Tool again? Download only? Firmware upgrade? First preloader then everything else?
Reply
#8
(07-08-2017, 11:39 AM)МиливојКовачевић Wrote: It' not removable. Or at least not if I don't open it somehow, but the only screw which should be unscrewed to open it is somehow stuck. 
So what's the best option to use now, if I'm going to flash it with SP Flash Tool again? Download only? Firmware upgrade? First preloader then everything else?

Flash with firmware upgrade.
I would advise you have the battery taken out for you, just incase it needs to be externally boosted
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#9
Tried firmware upgrade with different versions of the tool and of the firmware. Most of the times I get "Failed to get PMT info." error: 

.png   screenshot-1.png (Size: 73.78 KB / Downloads: 2)
Sometimes I get "Failed to open COM port.":

.png   screenshot-2.png (Size: 69.66 KB / Downloads: 2)
Tried 3 different USB ports, 3 different firmware versions and 3 different SP Flash Tool versions (5.1628, 5.1614, 5.1644).
I even got this error couple of times:  

.png   screenshot-3.png (Size: 71.45 KB / Downloads: 2)


If I try "Download only" everything seams to go fine. Oh, and by the way, I keep external SD card inside the phone. Is this ok, or should I remove it?

And how would I boost the battery in case I manage to take it out?
Reply
#10
(07-10-2017, 03:45 PM)МиливојКовачевић Wrote: Tried firmware upgrade with different versions of the tool and of the firmware. Most of the times I get "Failed to get PMT info." error: 

Sometimes I get "Failed to open COM port.":

Tried 3 different USB ports, 3 different firmware versions and 3 different SP Flash Tool versions (5.1628, 5.1614, 5.1644).
I even got this error couple of times:  



If I try "Download only" everything seams to go fine. Oh, and by the way, I keep external SD card inside the phone. Is this ok, or should I remove it?

And how would I boost the battery in case I manage to take it out?

All these are problems connecting to the device.
Doesn't matter whether or not there's an SD card inserted
Just taking out and re-inserting the battery could help it to begin charging normally again
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)