Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] My Infinix X507 wont boot or charge.

#1

my battery ran down a day before and since then i tried charging my battery but it has refused to charge. it keeps showing me the charge logo on a constant loop i.e it appears then disappears then appears, then disappears.. tried turning it on, it shows the infinix logo and goes back to the charge logo. please i need access to download the stock rom for the x507 i would be immensely grateful or at least tell me where i can find it.


Reply
#2
my email address is [email protected]
Reply
#3
(03-23-2015, 12:17 AM)louizzy Wrote: my battery ran down a day before and since then i tried charging my battery but it has refused to charge. it keeps showing me the charge logo on a constant loop i.e it appears then disappears then appears, then disappears.. tried turning it on, it shows the infinix logo and goes back to the charge logo. please i need access to download the stock rom for the x507 i would be immensely grateful or at least tell me where i can find it.

your battery is drained and needs to be boosted. take it out and boost using an external charger.
anyways, granted! download @ https://forum.hovatek.com/thread-533.html and flash system.img (Android) using Sp flash tool @ https://forum.hovatek.com/thread-159.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)