Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Infinix surf spice x403 totally bricked

#11

Helloooo boss....thank you very much. After pressing the volume up and down button several times, it boot on its own and the phone is back to life.am grateful to you Admin and the crew.


Reply
#12
Pls i need help flash rom backup for infinix x403
Reply
#13
(05-20-2015, 11:03 AM)rico suave Wrote: Pls i need help flash rom backup for infinix x403

create a new thread, this is someone else's support thread

see https://forum.hovatek.com/thread-514.html for how to create a thread
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#14
(This post was last modified: 08-14-2015, 07:29 AM by bazilfaquih. )
(04-10-2015, 04:58 PM)hovatek Wrote:
(04-10-2015, 12:52 PM)redeemer kbee Wrote: my infinix surf spice x403 is totally bricked(dead) and it cannot boot again nor even charge with a  logo...anytime i connect it to my pc. the pc makes sound and its been a month now. am panic please i need help.thanks.

supply a gmail address for the stock ROM

[email protected]
Reply
#15
(08-14-2015, 07:28 AM)bazilfaquih Wrote: [email protected]

create a new thread, this is someone else's support thread
see https://forum.hovatek.com/thread-514.html for how to create a thread

Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#16
Hellooooo administrator.... Please my infinix surf spice x403 has been giving me a problem with the SD card....... It always says memory card unexpectedly removed and I have to restart the phone before it comes because the mount section at the storage side is always blank after that happen.... I bought a new memory card and still the same problem...... please help me fix it.
Reply
#17
(09-12-2015, 03:00 PM)redeemer kbee Wrote: Hellooooo administrator.... Please my infinix surf spice x403 has been giving me a problem with the SD card....... It always says memory card unexpectedly removed and I have to restart the phone before it comes because the mount section at the storage side is always blank after that happen.... I bought a new memory card and still the same problem......  please help me fix it.

create a new thread for this to avoid a mixup
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)