Hi, Guest! Login / Register




Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Tutorial] How to fix a totally dead MTK phone; wont come on, charge or show any sign of life


(10-29-2015, 09:24 PM)Omegaohms Wrote: If the phone only vibrates and nothing happens does dat mean that the preloader of the fon is still ok?

Possibly


Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
(10-30-2015, 09:37 AM)Timimaryz Wrote: mori peeps, i just tried to flash my m3 and i formatted it using the sp flashtool by choosing "format whole flash". and ever since my pc can't detect my m3 again. i ve tried uninstalling and reinstalling the driver and even used USBVIEW to removed the drivers still no avail. pls i need help to fix this phone. thanks!

create a new thread so we focus on this

see https://forum.hovatek.com/thread-514.html for how to create a thread
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
(05-14-2014, 03:07 AM)hovatek Wrote: * Note: This procedure is the same for all MTK Android phones (e.g Tecno, Gionee, Infinix, Opsson, Innjoo, TLC, Lead1 etc) but the backup files to be used differ

If you accidentally bricked your MTK phone through whatever means then see:
How to Unbrick / fix a bricked Tecno phone
How to Unbrick / fix a bricked Gionee phone

Some people; however, attempt unbricking / fixing their bricked MTK phones using either the wrong procedure or OS files. As a result, their devices get worse. The phones enter into a higher level of unbricking whereby, they don't even boot or charge any more, just dead. Even pressing the power button would have no effect in such a scenario. What has happened is called a corrupted or missing Preloader (preloader.bin).
We wont go into details about the function of the Preloader but one function - which you must've figured out by now - is that it helps make your MTK phone boot. To fix the problem of a Corrupted / missing Preloader, you'll need the following:

Tools needed

* Download SP Flash Tool
* PC
* USB Cord
* If you have access to a working phone of the same model then follow this guide @ http://forum.hovatek.com/thread-468.html to make an MTK backup which should contain Preloader.bin and all other files you'll need
* If you don't have access to a working phone of the same model then download an MTK backup for your phone model @:

Tecno Stock ROMs
Gionee Stock ROMs
Infinix Stock ROMs
Opsson Stock ROMs

* If the MTK backup doesn't contain preloader.bin then download preloader.bin for your phone model ( Preloader.bin for Tecno phones only )


Procedure

* Using SP Flash Tool, flash the preloader.bin first (see SP Flash tool guide @ http://forum.hovatek.com/thread-159.html ).
* If flashing was successful then your phone should at least be able to vibrate when you press the power button or boot if the correct files are present on your phone; else, flash other necessary files to make the phone boot up and start working normally again.

Hello! 

Before I state my issue, i just want to say I really apreaciate this forum specially hovatek for accomodating a lot of question. Almost all of the questions ask you have answered. Really kudos to you guys! Setting the praises aside. Here's my issue.

My phone of concern is not listed on the list it Cherry mobile flare xl with mtk 6592. Anyway it started with some one trying to flash a custom rom. It ended up in a boot loop with a distorted google image. Assuming the one who flashed it tried to flash a different rom, I tried to look for a stock rom. Gladly found one, for flare xl x340 in a form of scatter file. So I went to SPFT. The phone is not detected when battery is removed soI put in the battery. What happen is when the screen is black it detects the device but when the screen turns on with the distorted google it disconnects. What I did is just click the download and connect the usb to the phone. amazingly it worked and SPFT flashed the rom. Now here comes the next problem, i forgot to uncheck the preloader. After flashing the phone went dead. Although when connecting the us windows stil detects it as "mediatek usb port(comx)". Reding from your post and others it means i still have a chance cause its entering into "meta mode". so I assume that the preloader is corrupted. I tried to find another source of a stock from and found it in needroms. Now It sound hopeful, but another problem rises. When download is clicked SPFT ALWAYS RETURNS a brom error 4032. Again the phone is detected as Mediatek usb port and i have done the steps click download, put in the battery, then plug the usb. The computer doesnot detect the phone when battry is removed. Is there still hope?    Big Grin
Reply
(11-05-2015, 03:03 AM)ron15 Wrote: Hello! 

Before I state my issue, i just want to say I really apreaciate this forum specially hovatek for accomodating a lot of question. Almost all of the questions ask you have answered. Really kudos to you guys! Setting the praises aside. Here's my issue.

My phone of concern is not listed on the list it Cherry mobile flare xl with mtk 6592. Anyway it started with some one trying to flash a custom rom. It ended up in a boot loop with a distorted google image. Assuming the one who flashed it tried to flash a different rom, I tried to look for a stock rom. Gladly found one, for flare xl x340 in a form of scatter file. So I went to SPFT. The phone is not detected when battery is removed soI put in the battery. What happen is when the screen is black it detects the device but when the screen turns on with the distorted google it disconnects. What I did is just click the download and connect the usb to the phone. amazingly it worked and SPFT flashed the rom. Now here comes the next problem, i forgot to uncheck the preloader. After flashing the phone went dead. Although when connecting the us windows stil detects it as "mediatek usb port(comx)". Reding from your post and others it means i still have a chance cause its entering into "meta mode". so I assume that the preloader is corrupted. I tried to find another source of a stock from and found it in needroms. Now It sound hopeful, but another problem rises. When download is clicked SPFT ALWAYS RETURNS a brom error 4032. Again the phone is detected as Mediatek usb port and i have done the steps click download, put in the battery, then plug the usb. The computer doesnot detect the phone when battry is removed. Is there still hope?    Big Grin

create a new thread so we focus on this
see https://forum.hovatek.com/thread-514.html for how to create a thread
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
(This post was last modified: 11-10-2015, 03:18 PM by a4apple. )
My lenovo A606 is dead.. It has MT6582.. It all happen like this. I root the device without any issue with Kingoroot. Well, i played around, flash custom (TWRP) recovery, and create stock backup (TWRP and MTKDroid) in case anything happen. Well, bad thing happen when I started to google for latest firmware and I found it. So i proceed to watch some videos on how to flash roms/update firmware with SPflash. So then I proceed with confident and the update was successful (green tick shown in SPflash) but it wasnt success on the phone.. It couldnt boot at all. It cant be detect with my laptop, no sign on charging, cant power on, nothing.. When I plugged the USB onto the laptop, it doesnt make a sound or vibrate, it simply like i didnt plug anything into my laptop.. Please help me.. I've sent it to different technicians to fix but they cant fix it. I searched for a very long time and got this forum.. Please help me Sad

EDIT/UPDATE
My laptop gives some "da-dun" sound but the driver installed as "Alcatel Single RNDIS Interface" in the network adapters category.. Sad
Reply
(11-10-2015, 02:20 PM)a4apple Wrote: My lenovo A606 is dead.. It has MT6582.. It all happen like this. I root the device without any issue with Kingoroot. Well, i played around, flash custom (TWRP) recovery, and create stock backup (TWRP and MTKDroid) in case anything happen. Well, bad thing happen when I started to google for latest firmware and I found it. So i proceed to watch some videos on how to flash roms/update firmware with SPflash. So then I proceed with confident and the update was successful (green tick shown in SPflash) but it wasnt success on the phone.. It couldnt boot at all. It cant be detect with my laptop, no sign on charging, cant power on, nothing.. When I plugged the USB onto the laptop, it doesnt make a sound or vibrate, it simply like i didnt plug anything into my laptop.. Please help me.. I've sent it to different technicians to fix but they cant fix it. I searched for a very long time and got this forum.. Please help me Sad

EDIT/UPDATE
My laptop gives some "da-dun" sound but the driver installed as "Alcatel Single RNDIS Interface" in the network adapters category.. Sad


create a new thread so we focus on this see https://forum.hovatek.com/thread-514.html for how to create a thread
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
Pls help me!!! I had a infinix hot x507 which fell on the ground and it's hard bricked with no sign of life. So I download a mtk backup from your site and flash the preloader.bin and the rest of the files but still it won't come up. I can only feel the vibration, nothing more. Please I need to know what more I can do please. My phone has been dead since a month now. Help me out, would be so grateful thanks and God bless Hovatek!
Reply
(11-14-2015, 02:17 PM)democax Wrote: Pls help me!!! I had a infinix hot x507 which fell on the ground and it's hard bricked with no sign of life. So I download a mtk backup from your site and flash the preloader.bin and the rest of the files but still it won't come up. I can only feel the vibration, nothing more. Please I need to know what more I can do please. My phone has been dead since a month now. Help me out, would be so grateful thanks and God bless Hovatek!

create a new thread so we focus on this see https://forum.hovatek.com/thread-514.html for how to create a thread

Reply
hello guys pls I need your help, am in need of perloaded.bin for infinix x403
Reply
(This post was last modified: 11-16-2015, 12:25 PM by irishab. )
pls grant me permission to download infinix x403 stock Rom
these is my gmail [email protected]
Reply










Users browsing this thread:
1 Guest(s)