Hi, Guest! Login / Register




Thread Rating:
  • 41 Vote(s) - 4.9 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Downloads] Collection of Tecno stock ROMs / firmware


(09-01-2014, 08:40 PM)opta Wrote: am very sure. Its black which is Image A. But i notice sumtin wen i bought it dx year. Wen i compare it wit first versn of m3. There is a little different in setting>about phone. Can dx affect it?

dere is where dy wrote june in other phone bt mine is august.

Just as suspected. The Tecno M3 backup on our website is for the old M3 and will be incompatible with yours. We just acquired the MTK backup for the new M3 but are yet to upload it.


Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
(09-01-2014, 10:14 PM)Mcoul15 Wrote: Hello!
After restore (backup cwm stock rom for p5) via cwm my tecno don't boot.
If I try to boot , The screen goes out and ignites automatically, several times without limit!
Help me

Can the phone still boot into recovery mode? if it can then do a factory reset, if not then you'll need to flash the MTK backup
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
(09-01-2014, 10:26 PM)mboy13 Wrote: bro, i jst notice nw dat ma blue led light is no displayin any more ever since i flash ma tecno Q1 even wen am chargin it. i also notic dat i cnt mak call wit ma mtn line nor check balance on it, bt i got dat fix by changin bck d imei numba. pls help on d led light.

have you done a factory reset and davlink cache wipe?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
(09-01-2014, 10:37 PM)hovatek Wrote:
(09-01-2014, 08:40 PM)opta Wrote: am very sure. Its black which is Image A. But i notice sumtin wen i bought it dx year. Wen i compare it wit first versn of m3. There is a little different in setting>about phone. Can dx affect it?

dere is where dy wrote june in other phone bt mine is august.

Just as suspected. The Tecno M3 backup on our website is for the old M3 and will be incompatible with yours. We just acquired the MTK backup for the new M3 but are yet to upload it.

thanks 4 ur help. I wil b expecting ur update.
(09-01-2014, 10:40 PM)hovatek Wrote:
(09-01-2014, 10:14 PM)Mcoul15 Wrote: Hello!
After restore (backup cwm stock rom for p5) via cwm my tecno don't boot.
If I try to boot , The screen goes out and ignites automatically, several times without limit!
Help me

Can the phone still boot into recovery mode? if it can then do a factory reset, if not then you'll need to flash the MTK backup

Yes, the phone can still boot recovery mode! I do factory reset&data but it does not work.
If I must make MTK BACKUP, hot it work?

(This post was last modified: 09-02-2014, 11:16 AM by hovatek. )
(09-02-2014, 01:16 AM)Mcoul15 Wrote: Yes, the phone can still boot recovery mode! I do factory reset&data but it does not work.
If I must make MTK BACKUP, hot it work?

To flash the MTK backup to your phone using Sp Flash tool, follow this guide @ http://forum.hovatek.com/thread-159.html and flash only boot.img and system.img .

But before you proceed with the Sp Flash tool method, format the memory card > slot it back in > boot the phone and lets know how that goes
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
I'll try it , but sp flash doesn't work for me. If I try to find scatter file , that'll be an error
My tecno f7 3g network comes and goes instantly on all networks evwn if i set it at 3g only it still does the same thing tis is very frustrating
(This post was last modified: 09-02-2014, 02:32 PM by hovatek. )
(09-02-2014, 11:47 AM)Mcoul15 Wrote: I'll try it , but sp flash doesn't work for me. If I try to find scatter file , that'll be an error

What version of sp flash tool are you using? also, what's your phone model so we so we Grant you download permission for the MTK backup
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
(09-02-2014, 01:09 PM)stormy Wrote: My tecno f7 3g network comes and goes instantly on all networks evwn if i set it at 3g only it still does the same thing tis is very frustrating

did you ever change your imei?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)










Users browsing this thread:
1 Guest(s)