Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 41 Vote(s) - 4.9 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Downloads] Collection of Tecno stock ROMs / firmware


(09-22-2014, 04:36 AM)chaiko Wrote: my question is must i download this particular backed up rom before keslar rom works in my M3 or do i use the ROM in my phone?  old ROM.  because i have downloaded this your particular rom completely but fails to install. instead is says installation aborted.

If you keep getting this error, its either the ROM wasn't properly / completely downloaded (consider re-downloading it) or your Tecno M3 is the new type (see http://forum.hovatek.com/thread-3111.html for pictures of old and new )


Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
I need the link for Tecno L3 Please.
yet another error.
BROM ERROR: S_DA_NAND_FLASH_NOT_FOUND(3012)
[H/W] DA didn't detect NAND flash on the phone.
good day people please i was to request for access to download Tecno H5 (MTK Backup) & Tecno H5 (Clockworkmod Backup)
hovat Wrote:
windhunter Wrote:Pls could you grant me permission to download Tecno M7 backup https://hovatek.com/redirect.php?link=ht...hor=backup
My email is [email protected]
Thanks.

granted!
Ok thanks. I followed the procedure stated on this site and flashed the backup to the phone. Even after flasing several times it didn't boot up. I decided to try the last option which is the upgrade option and the phone is in a worse condition now. The phone is just dead. It doesn't display the tecno bootup screen anymore neither does it boot into recovery like it could do before i used the upgrade option on the SP flash tool. Whenever i try reflashing i get BROM_ERROR : S_DL_GET_DRAM_SETTING_FAIL (5054). What should i do. I don't have the preloader.bin file to flash to the phone. I couldn't find it on this site either. What should i do?
(09-22-2014, 10:25 AM)savedmoses21 Wrote: I need the link for Tecno L3 Please.

granted! The link is on page 1 of this thread.
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
(This post was last modified: 09-22-2014, 11:04 AM by hovatek. )
(09-22-2014, 10:37 AM)Agumba1 Wrote: yet another error.
BROM ERROR: S_DA_NAND_FLASH_NOT_FOUND(3012)
[H/W] DA didn't detect NAND flash on the phone.
Post this complaint @ http://forum.hovatek.com/thread-439.html
 
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
(09-22-2014, 10:38 AM)eti9 Wrote: good day people please i was to request for access to download Tecno H5 (MTK Backup) & Tecno H5 (Clockworkmod Backup)

granted for H5 MTK backup. request for CWM backup in a few hours
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
(09-22-2014, 10:44 AM)windhunter Wrote: Ok thanks. I followed the procedure stated on this site and flashed the backup to the phone. Even after flasing several times it didn't boot up. I decided to try the last option which is the upgrade option and the phone is in a worse condition now. The phone is just dead. It doesn't display the tecno bootup screen anymore neither does it boot into recovery like it could do before i used the upgrade option on the SP flash tool. Whenever i try reflashing i get BROM_ERROR : S_DL_GET_DRAM_SETTING_FAIL (5054). What should i do. I don't have the preloader.bin file to flash to the phone. I couldn't find it on this site either. What should i do?

That means you didnt follow the SP flash tool guide @ http://forum.hovatek.com/thread-159.html correctly. Since your phone could still boot, you only needed to have flashed system.img (Android). Apparently, you tried flashing all. Read http://forum.hovatek.com/thread-439.html and post further comments / complaints there
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
During the restoring process I got a mismatch md5 error.. Please help ASAP.










Users browsing this thread:
4 Guest(s)