Hi, Guest! Login / Register




Thread Rating:
  • 41 Vote(s) - 4.9 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Downloads] Collection of Tecno stock ROMs / firmware


Pls I need permission to download tecno l3 mtk backup @ [email protected]


(10-03-2014, 08:32 PM)bravo112 Wrote: Pls I need permission to download tecno l3 mtk backup @ [email protected]

granted!
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Pls Help,i Download Stock Mtk Rom 4 Phantom Pad N9,flashed Thru Sp Tool,showed Green Circle,rebooted And Stuck On TECNO LOGO,ANY HELP?
pls can i ve de mtk backup of m3 here
my email is [email protected]
pls ok
(10-03-2014, 11:00 PM)samtobi042 Wrote: Pls Help,i Download Stock Mtk Rom 4 Phantom Pad N9,flashed Thru Sp Tool,showed Green Circle,rebooted And Stuck On TECNO LOGO,ANY HELP?

please, create a new thread for this by clicking http://forum.hovatek.com/newthread.php?fid=4

Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
(10-04-2014, 02:34 AM)EMILEO90 Wrote: pls can i ve de mtk backup of m3 here
my email is [email protected]
pls ok

granted!
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
IT DIDNT DIRECT ME TO DOWNLOAD LINK
(10-04-2014, 10:48 AM)EMILEO90 Wrote: IT DIDNT DIRECT ME TO DOWNLOAD LINK

as in?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
hey. i tried my tecno h5 using sp flash tool but after the download is complete the phone still doesn't reboot. i tried upgrading the firmware but i get a brom error and since i downloaded the back up from your website, i dont understand what the problem could be. please i need your assistance.
(10-05-2014, 04:34 AM)joe Wrote: hey. i tried my tecno h5 using sp flash tool but after the download is complete the phone still doesn't reboot. i tried upgrading the firmware but i get a brom error and since i downloaded the back up from your website, i dont understand what the problem could be. please i need your assistance.

please create a new thread by clicking http://forum.hovatek.com/newthread.php?fid=4
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)










Users browsing this thread:
5 Guest(s)