Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] TECNO D7 IS DEAD

#11

I was able to successfully flash in the Tecno D7 files (Preloader and system img), but the phone is still dead. I used desktop / universal charger to get the battery to full charge, but still not responding.


Reply
#12
Any ideas on what to do next?
Reply
#13
I was able to successfully flash in the Tecno D7 files (Preloader and system img), but the phone is still dead. I used desktop / universal charger to get the battery to full charge, but still not responding.
Reply
#14
(05-10-2015, 11:43 PM)mike03 Wrote: I was able to successfully flash in the Tecno D7 files (Preloader and system img), but the phone is still dead. I used desktop / universal charger to get the battery to full charge,  but still not responding.

flash all the files in the backup to the phone
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#15
Thanks Hovatek. After flashing all the backup files to the phone, the battery charging logo appears, showing 89%. That means the phone is revived, but nothing else. The power button is not powering the phone. Please what should I do next?
Reply
#16
Should I flash the phone again?
Reply
#17
(05-11-2015, 02:35 PM)mike03 Wrote: Should I flash the phone again?

take out the battery , slot back in and try booting
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#18
Thanks. I've done that but it's not powering on. The power button was bad, that's why I flashed it, before the SP Flash tool got interrupted. After flashing the Tecno D7 system files, I expected the power button to work. But it's not still working. The battery is 100% charged now. Please what should I do? Thanks for your support so far

Reply
#19
(05-11-2015, 07:43 PM)mike03 Wrote: Thanks. I've done that but it's not powering on. The power button was bad, that's why I flashed it, before the SP Flash tool got interrupted. After flashing the Tecno D7 system files, I expected the power button to work. But it's not still working. The battery is 100% charged now. Please what should I do?  Thanks for your support so far

you need to unscrew it and press the power button directly 
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#20
Thanks Hovatek. I did as you said, the power button responded. But didn't bot beyond tecno boot logo. So I boot it to factory mode. After that, I flashed in the Tecno D7 file (system img) and the phone is working well now.
Thank you very much for being there for us.
Reply










Users browsing this thread:
1 Guest(s)