Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] TECNO D7 IS DEAD

#1

Please help with my tecno D7. I was carrying out data wipe/formatting using SP Flash Tool, I mistakenly unplugged the phone while the process was going on. Now the phone is totally dead. It doesn't boot at all. Please tell me what to do.

I will be very grateful for your support.


Reply
#2
I have the backup files for Tecno D7.
Reply
#3
Please what should I do?
Reply
#4
(05-09-2015, 08:11 AM)mike03 Wrote: Please help with my tecno D7. I was carrying out data wipe/formatting using SP Flash Tool, I mistakenly unplugged the phone while the process was going on. Now the phone is totally dead. It doesn't boot at all. Please tell me what to do.

I will be very grateful for your support.

1. Was formatting succesful in sp flash tool or you interrupted it during the format process
2. Read the guide @ https://forum.hovatek.com/thread-808.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
Thanks for your support. I've followed the guide, I've been charging the phone for more than 7 hours now, but it's not responding yet.
Reply
#6
(This post was last modified: 05-10-2015, 03:24 AM by hovatek. )
(05-09-2015, 11:43 PM)mike03 Wrote: Thanks for your support. I've followed the guide,  I've been charging the phone for more than 7 hours now, but it's not responding yet.
uninstall then re-install vcom drivers using https://forum.hovatek.com/thread-440.html then try flashing the files using sp flash tool again
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#7
Thanks for your support. The phone is still dead. I've been charging it for over thirty hours now but it's not responding. Should I go ahead with the flashing process.?
Reply
#8
If I have battery of the same phone, can it make the phone work?

Reply
#9
(05-10-2015, 05:45 PM)mike03 Wrote: Thanks for your support. The phone is still dead. I've been charging it for over thirty hours now but it's not responding. Should I go ahead with the flashing process.?

yes, proceed with flashing but first uninstall then re-install vcom drivers using  https://forum.hovatek.com/thread-440.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#10
Thanks. I will do as you say. I will let you know the outcome
Reply










Users browsing this thread:
1 Guest(s)