Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] how to restore a dead tecno m9

#1

My m9 got bricked, After trying to unbrick d m9... D phone is dead totally ... Hav use my sp flash tools to flash several phones .... Bt its not recognizing this m9..the phone is nt even cuming on at all, even when plug on charge... What should i do pls


Reply
#2
(05-14-2015, 05:08 AM)omosko Wrote: My m9 got bricked, After trying to unbrick d m9... D phone is  dead totally ... Hav use my sp flash tools to flash several phones  .... Bt its not recognizing this m9..the phone is nt even cuming on at all, even when plug on charge... What should i do pls

do you have the m9 stock ROM or a working M9 there?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
(05-14-2015, 05:08 AM)omosko Wrote: My m9 got bricked, After trying to unbrick d m9... D phone is dead totally ... Hav use my sp flash tools to flash several phones .... Bt its not recognizing this m9..the phone is nt even cuming on at all, even when plug on charge... What should i do pls

We have the same problem my brother......its not just recognizing my m9.....

Sent from my Infinix X507 using Hovatek mobile
Reply
#4
(05-14-2015, 05:08 AM)omosko Wrote: My m9 got bricked, After trying to unbrick d m9... D phone is dead totally ... Hav use my sp flash tools to flash several phones .... Bt its not recognizing this m9..the phone is nt even cuming on at all, even when plug on charge... What should i do pls

I have downloaded the stock rom for the m9.....

Sent from my Infinix X507 using Hovatek mobile
Reply
#5
(05-14-2015, 10:42 AM)fabkeyz Wrote:
(05-14-2015, 05:08 AM)omosko Wrote: My m9 got bricked, After trying to unbrick d m9... D phone is dead totally ... Hav use my sp flash tools to flash several phones .... Bt its not recognizing this m9..the phone is nt even cuming on at all, even when plug on charge... What should i do pls

I have downloaded the stock rom for the m9.....

Sent from my Infinix X507 using Hovatek mobile

Please can you give me the link to the stock rom?
Reply
#6
(05-14-2015, 05:08 AM)omosko Wrote: My m9 got bricked, After trying to unbrick d m9... D phone is  dead totally ... Hav use my sp flash tools to flash several phones  .... Bt its not recognizing this m9..the phone is nt even cuming on at all, even when plug on charge... What should i do pls

(08-01-2015, 03:13 PM)KikiAkane Wrote: Please can you give me the link to the stock rom?

we've uploaded the M9 MTK backup
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#7
(08-01-2015, 07:59 PM)hovatek Wrote:
(05-14-2015, 05:08 AM)omosko Wrote: My m9 got bricked, After trying to unbrick d m9... D phone is  dead totally ... Hav use my sp flash tools to flash several phones  .... Bt its not recognizing this m9..the phone is nt even cuming on at all, even when plug on charge... What should i do pls

(08-01-2015, 03:13 PM)KikiAkane Wrote: Please can you give me the link to the stock rom?

we've uploaded the M9 MTK backup
Thanks. Actually, I've opened a new thread with the details, but I've not heard back
Reply
#8
(08-02-2015, 03:53 PM)KikiAkane Wrote:
(08-01-2015, 07:59 PM)hovatek Wrote:
(05-14-2015, 05:08 AM)omosko Wrote: My m9 got bricked, After trying to unbrick d m9... D phone is  dead totally ... Hav use my sp flash tools to flash several phones  .... Bt its not recognizing this m9..the phone is nt even cuming on at all, even when plug on charge... What should i do pls

(08-01-2015, 03:13 PM)KikiAkane Wrote: Please can you give me the link to the stock rom?

we've uploaded the M9 MTK backup
Thanks. Actually, I've opened a new thread with the details, but I've not heard back

Same prob here.tecno m9 totally dead and not powering on BT I made a cmw back up.what do I do
Reply
#9
(08-23-2015, 07:57 AM)charlixman Wrote: Same prob here.tecno m9 totally dead and not powering on BT I made a cmw back up.what do I do

create a new thread, this is someone else's support thread
see https://forum.hovatek.com/thread-514.html for how to create a thread
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)