Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] M-HORSE POWER OFF BY ITSELF

#1

Hi, M-horse with the model X when on it only display Nokia and switch off. It developed the problem by itself. Pls how can I fix it cos it seems like it need to be flash.


Reply
#2
(05-14-2015, 12:38 PM)Twonity Wrote: Hi, M-horse with the model X when on it only display Nokia and switch off. It developed the problem by itself. Pls how can I fix it cos it seems like it need to be flash.

whats the full model name?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
(05-14-2015, 02:15 PM)hovatek Wrote:
(05-14-2015, 12:38 PM)Twonity Wrote: Hi, M-horse with the model X when on it only display Nokia and switch off. It developed the problem by itself. Pls how can I fix it cos it seems like it need to be flash.

whats the full model name?

All I can see its M-HORSE Model:X
Reply
#4
(05-14-2015, 09:30 PM)Twonity Wrote: All I can see its M-HORSE Model:X

didnt find much on quick search. do you know the specs like OS version & chipset
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
(05-15-2015, 08:43 AM)hovatek Wrote:
(05-14-2015, 09:30 PM)Twonity Wrote: All I can see its M-HORSE Model:X

didnt find much on quick search. do you know the specs like OS version & chipset

I can't tell about the OS version but the chipset is spreadstrum 
Reply
#6
(05-15-2015, 08:45 AM)Twonity Wrote:
(05-15-2015, 08:43 AM)hovatek Wrote:
(05-14-2015, 09:30 PM)Twonity Wrote: All I can see its M-HORSE Model:X

didnt find much on quick search. do you know the specs like OS version & chipset

I can't tell about the OS version but the chipset is spreadstrum 

cpu= sc6531 chipset= spreadtrum.
name= M-HORSE Model X
Reply
#7
(05-15-2015, 09:13 AM)omoabugan Wrote: cpu= sc6531 chipset= spreadtrum.
name= M-HORSE Model X

if the battery is removable then charge it using a desktop charger for 3-4 hours and try powering on again. if it persists then you might need to flash the pac file using this guide @ https://forum.hovatek.com/thread-1231.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)