Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Dead infinix hot

#1

My infinix x507 is dead. It wont charge nor power up, can't even boot on recovery mode just blank after formatting it using the sp flash tool. Kindly provide me with the necessary files to make it work again.
Email: [email protected]
Thanks.


Reply
#2
Same with me
[email protected]
Reply
#3
(05-26-2015, 04:52 AM)larry Wrote: My infinix x507 is dead. It wont charge nor power up, can't even boot on recovery mode just blank after formatting it using the sp flash tool. Kindly provide me with the necessary files to make it work again.
Email: [email protected]
Thanks.

granted! download @ https://forum.hovatek.com/thread-533.html and flash using Sp flash tool @ https://forum.hovatek.com/thread-159.html
Reply
#4
(05-26-2015, 05:12 AM)1legend Wrote: Same with me
[email protected]

create a new thread, this is someone else's support thread

see https://forum.hovatek.com/thread-514.html for how to create a thread
Reply
#5
(05-26-2015, 12:24 PM)hovatek Wrote:
(05-26-2015, 04:52 AM)larry Wrote: My infinix x507 is dead. It wont charge nor power up, can't even boot on recovery mode just blank after formatting it using the sp flash tool. Kindly provide me with the necessary files to make it work again.
Email: [email protected]
Thanks.

granted! download @ https://forum.hovatek.com/thread-533.html and flash using Sp flash tool @ https://forum.hovatek.com/thread-159.html

After successfully flashing the phone,thanks for the flash files; the touchscreen is now totally unresponsive on some parts. it then behaves as if someone is touching the screen and keeps opening apps and dialing by itself.
please help.
Reply
#6
(05-27-2015, 02:15 AM)larry Wrote: After successfully flashing the phone,thanks for the flash files; the touchscreen is now totally unresponsive on some parts. it then behaves as if someone is touching the screen and keeps opening apps and dialing by itself.
please help.

slot in a formatted SD card and do a factory reset
Reply










Users browsing this thread:
1 Guest(s)