Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

How To Fix Google Play store "check your connection and try again"

#1

I will be posting different methods on how to fix google play store errors. I had the same problem long time ago  but now I know how to fix it.

METHOD 1 :-

● Goto Settings >Date & Time
● Set the device to  manual and set year to 4 years in the future, then open to the Play Store, Once play store Opens without the 'connection error'
●Go back to time settings and reset to Automatic, then everything is okay!

METHOD 2  (Root needed)

The problem can be  resolve  by removing host file /etc/hosts file.
REQUIREMENTS: -  
● You must be Rooted, before you follow my simple guide.
● DOwnload Root Explorer, to access the file.
●Launch Root explorer, Scrol down and look for etc folder
●Cick to open the etc folder and locatefolder and delete  hosts files, better, instead of removing the file rename it to something else, so that you can restore it back if needed or backup the host file before deleting . Sometimes you need to reboot the phone, sometimes it works straight away and if it doesn't work straight up just restart.

METHOD 3 (wifi connection needed)

● Get connected to a wireless connection
● Move to the Wi-Fi settings and press and hold on the network your device is connected to. Then tap the ‘Modify’ button.
● Tick the ‘Advanced Options’ button and then proceed.
● Scroll down further and change IP Settings from ‘DHCP’ to Static.
● Change DNS 1 to 208.67.222.222 and DNS 2 to 208.67.220.220
● Press Save and exit the Wi-Fi settings. Now, move on to your list of Apps in Settings and select the ‘All’ Apps section.
● Clear Cache on Google Play Store, Google Play Services and Google Services Framework.

Reboot your phone (optional). Now your Play Store will work and you won’t have the ‘No Connection’ error any longer.


Reply
#2
I have done all this still telling me network connection failed

Sent from my P2S using Hovatek mobile
Reply
#3
(06-08-2015, 10:07 AM)Phartone Wrote: I have done all this still telling me network connection failed

Sent from my P2S using Hovatek mobile

Follow the method two(2) and restart your device, once restart is completed turn on your data make sure your connection is working well enable Auto-Sync Data open play store and wait don't minimize the play store just open and wait until a pop up comes up and click accept
Reply
#4
(06-08-2015, 10:39 AM)Spondulix Wrote:
(06-08-2015, 10:07 AM)Phartone Wrote: I have done all this still telling me network connection failed

Sent from my P2S using Hovatek mobile

Follow the method two(2) and restart your device,  once restart is completed turn on your data make sure your connection is working well  enable Auto-Sync Data open play store and wait don't minimize the play store just open and wait until a pop up comes up and click accept
Reply
#5
This thread has actually helped to solve my GPS issue. Using the method 2 worked out for me but u try to use other methods attentively and it will work for you. Thanks hovatek
Reply
#6
(This post was last modified: 06-08-2015, 04:19 PM by hovatek. )
(06-08-2015, 01:01 PM)Phartone Wrote: This thread has actually helped to solve my GPS issue. Using the method 2 worked out for me but u try to use other methods attentively and it will work for you. Thanks hovatek

@Spondulix did it and deserves the credit
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)