Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Need Help! Totally Bricked Infinix X551 Need firmware and stock rom

#21

(07-01-2015, 12:11 PM)hovatek Wrote:
(07-01-2015, 07:58 AM)BazlEugene Wrote: So the phone is back on again... After removing the battery to achieve it. However, SP flash tool gives me an error code about the COM port no being opened... How do I resolve that?

Also I still need to flash the phone since my initial problem was the privacy protection lock... What files do i need to flash from the MTK backup?

for the port issue, try another USB cord , PC port or PC
for the privacy protection lock, follow the guide @ https://forum.hovatek.com/thread-1138.html

A major update.

I managed to flash the phone and after 2 or 3 tries it did get rid of the privacy password (*I had not formatted the phone the first 2 times and I didn't format the bootloader on the third try)

But here's the problem I have now. Everything is working fine except recognition and registering of simcards, bluetooth, and the internal speaker when playing music or videos.

I also checked the status of the phone's IMEIs and they are both unknown, the Bluetooth address is also unknown and I have no Baseband version registered for Android. My Serial Number is also messed.

How do I solve this?

I've included screenshot attachments for reference



Attached Files
.jpg   Screenshot 2.JPG (Size: 29.58 KB / Downloads: 1)
.jpg   Screen Shot 3.JPG (Size: 27.54 KB / Downloads: 1)
.jpg   Screenshot Address.JPG (Size: 34.43 KB / Downloads: 1)
Reply
#22
(07-02-2015, 07:31 AM)BazlEugene Wrote: A major update.

I managed to flash the phone and after 2 or 3 tries it did get rid of the privacy password (*I had not formatted the phone the first 2 times and I didn't format the bootloader on the third try)

But here's the problem I have now. Everything is working fine except recognition and registering of simcards, bluetooth, and the internal speaker when playing music or videos.

I also checked the status of the phone's IMEIs and they are both unknown, the Bluetooth address is also unknown and I have no Baseband version registered for Android. My Serial Number is also messed.

How do I solve this?

I've included screenshot attachments for reference

not having Baseband means you'll need to reflash the stock ROM (secro.img to be precise).
use SP flash tool v 5 and ensure to flash all files.
hope you flashed our own X551 stock backup
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#23
(This post was last modified: 07-02-2015, 01:15 PM by BazlEugene. )
(07-02-2015, 01:09 PM)hovatek Wrote:
(07-02-2015, 07:31 AM)BazlEugene Wrote: A major update.

I managed to flash the phone and after 2 or 3 tries it did get rid of the privacy password (*I had not formatted the phone the first 2 times and I didn't format the bootloader on the third try)

But here's the problem I have now. Everything is working fine except recognition and registering of simcards, bluetooth, and the internal speaker when playing music or videos.

I also checked the status of the phone's IMEIs and they are both unknown, the Bluetooth address is also unknown and I have no Baseband version registered for Android. My Serial Number is also messed.

How do I solve this?

I've included screenshot attachments for reference

not having Baseband means you'll need to reflash the stock ROM (secro.img to be precise).
use SP flash tool v 5 and ensure to flash all files.
hope you flashed our own X551 stock backup

I did use your backup... Do I have to format the whole phone plus the bootloader to fix everything?

How safe is it to do that though? What about my IMEIs?
Reply
#24
(07-02-2015, 01:13 PM)BazlEugene Wrote: I did use your backup... Do I have to format the whole phone plus the bootloader to fix everything?

How safe is it to do that though? What about my IMEIs?

no need to format, just flash all files using sp flash tool version 5
once you get your Baseband back, you can fix IMEI using https://forum.hovatek.com/thread-116.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#25
I have a same problem

Reply
#26
(07-21-2015, 12:24 AM)cassanov007 Wrote: I have a same problem

create a new thread, this is someone else's support thread

see https://forum.hovatek.com/thread-514.html for how to create a thread
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)