Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] Anyone to share NVRAM may be can solve this??

#1
Photo  (This post was last modified: 07-28-2015, 06:22 PM by hovatek. )

Hello Hovatek,

I have a Tecno L3 on hands, it was brought to me when it had a network problem, could not pick networks. So after i analysed it i found it had no imei's so i repaired the imei's succeffully with MTK DROIRD TOOLS.

But unfortunattelly the problem persisted, i re-flashed fully and then repaired imei's back again still didn't help.

The only thing that i have not tried so far is to try read NVRAM of a working phone and write on this, and that is because i don't have good one on my hands.


So anyone with any ideas or backup of nvram for L3 can help me.

From the image, one slot has simcard(The one with circle stuff) and the other one has no simcard. So that is the condition of the phone right now.

[Image: attachment.php?aid=1115]

By the way the Baseband is not unknown as someone may ask, also you can check some more info from the picture i capture from MTKDroid Tools.


.png   l3.PNG (Size: 49.05 KB / Downloads: 6)
Help me please.



Attached Files
.jpg   tecn l3.jpg (Size: 181.54 KB / Downloads: 20)
Reply
#2
(This post was last modified: 07-27-2015, 07:03 AM by hovatek. )
(07-26-2015, 01:59 PM)mobileTec Wrote: Hello Hovatek,

I have a Tecno L3 on hands, it was brought to me when it had a network problem, could not pick networks. So after i analysed it i found it had no imei's so i repaired the imei's succeffully with MTK DROIRD TOOLS.

But unfortunattelly the problem persisted, i re-flashed fully and then repaired imei's back again still didn't help.

The only thing that i have not tried so far is to try read NVRAM of a working phone and write on this, and that is because i don't have good one on my hands.


So anyone with any ideas or backup of nvram for L3 can help me.

From the image, one slot has simcard(The one with circle stuff) and the other one has no simcard. So that is the condition of the phone right now.



By the way the Baseband is not unknown as someone may ask, also you can check some more info from the picture i capture from MTKDroid Tools.


Help me please.

might be a hardware issue but lets explore all possible software related scenario such as a wrong baseband, airplane mode, radio set to off.....
how did you get the stock ROM you reflashed and did you do a factory reset after reflashing?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
(07-27-2015, 06:59 AM)hovatek Wrote:
(07-26-2015, 01:59 PM)mobileTec Wrote: Hello Hovatek,

I have a Tecno L3 on hands, it was brought to me when it had a network problem, could not pick networks. So after i analysed it i found it had no imei's so i repaired the imei's succeffully with MTK DROIRD TOOLS.

But unfortunattelly the problem persisted, i re-flashed fully and then repaired imei's back again still didn't help.

The only thing that i have not tried so far is to try read NVRAM of a working phone and write on this, and that is because i don't have good one on my hands.


So anyone with any ideas or backup of nvram for L3 can help me.

From the image, one slot has simcard(The one with circle stuff) and the other one has no simcard. So that is the condition of the phone right now.



By the way the Baseband is not unknown as someone may ask, also you can check some more info from the picture i capture from MTKDroid Tools.


Help me please.

might be a hardware issue but lets explore all possible software related scenario such as a wrong baseband, airplane mode, radio set to off.....
how did you get the stock ROM you reflashed and did you do a factory reset after reflashing?

I formatted whole except bootloader but the phone got stuck on tecno logo so i reflashed with a bin file and factory reset after flash and got that baseband it has now plus the repaired imei's.

So far i gues the nvram from the file with which i flashed the phone may be having problem that's why i suggested if anyone has a working phone and extract it's nvram and then i give it a try.

kind regards.
Reply
#4
(07-27-2015, 06:58 PM)mobileTec Wrote: I formatted whole except bootloader but the phone got stuck on tecno logo so i reflashed with a bin file and factory reset after flash and got that baseband it has now plus the repaired imei's.

So far i gues the nvram from the file with which i flashed the phone may be having problem that's why i suggested if anyone has a working phone and extract it's nvram and then i give it a try.

kind regards.

lets hope someone helps upload that.
what we have is the stock backup which contains secro.img. that should write a valid Baseband to the phone and rule out a baseband issue. one can then focus on IMEI and the chances of radio being set to off in engineering mode
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
(07-28-2015, 11:46 AM)hovatek Wrote:
(07-27-2015, 06:58 PM)mobileTec Wrote: I formatted whole except bootloader but the phone got stuck on tecno logo so i reflashed with a bin file and factory reset after flash and got that baseband it has now plus the repaired imei's.

So far i gues the nvram from the file with which i flashed the phone may be having problem that's why i suggested if anyone has a working phone and extract it's nvram and then i give it a try.

kind regards.

lets hope someone helps upload that.
what we have is the stock backup which contains secro.img. that should write a valid Baseband to the phone and rule out a baseband issue. one can then focus on IMEI and the chances of radio being set to off in engineering mode

Well i'm interested to try to flash secro.img file, but from the Stock Backup which i downloaded from your website does not contain that file and i went ahead tohttps://forum.hovatek.com/thread-336.html and download those rar files which contain secro.img,but i did not find it insteady secro.ext4.rar, or is there a way to convert it to img?

Reply
#6
(07-28-2015, 02:11 PM)mobileTec Wrote: Well i'm interested to try to flash secro.img file, but from the Stock Backup which i downloaded from your website does not contain that file and i went ahead tohttps://forum.hovatek.com/thread-336.html and download those rar files which contain secro.img,but i did not find it insteady secro.ext4.rar, or is there a way to convert it to img?

thats true. I recall the L3 secro.img issue myself. you'll need to get the NVRAM or secro.img from a working L3.
do a backup of your L3 using https://forum.hovatek.com/thread-468.html to see if a secro.img is created
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#7
(07-28-2015, 06:26 PM)hovatek Wrote:
(07-28-2015, 02:11 PM)mobileTec Wrote: Well i'm interested to try to flash secro.img file, but from the Stock Backup which i downloaded from your website does not contain that file and i went ahead tohttps://forum.hovatek.com/thread-336.html and download those rar files which contain secro.img,but i did not find it insteady secro.ext4.rar, or is there a way to convert it to img?

thats true. I recall the L3 secro.img issue myself. you'll need to get the NVRAM or secro.img from a working L3.
do a backup of your L3 using https://forum.hovatek.com/thread-468.html to see if a secro.img is created

Alright, i will keep struggling with those files(secro.img and nvram) and i will post results here if succeeded or not.
Reply










Users browsing this thread:
1 Guest(s)