Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Downloads] Tecno phantom Z

#1

Hello, I also need permission to download tecno phantom z (A7) stock rom. This is my email address [email protected] 
Thanks


Reply
#2
(08-30-2015, 09:41 AM)Shateemah Wrote: Hello, I also need permission to download tecno phantom z (A7) stock rom. This is my email address [email protected] 
Thanks

whats wrong with the phone and how did it happen?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
(08-30-2015, 09:41 AM)Shateemah Wrote: Hello, I also need permission to download tecno phantom z (A7) stock rom. This is my email address [email protected] 
Thanks

The phone has been misbehaving, the screen auto rotate is not responding, camera snaps pictures upside down. I have to rotate pictures 180 degrees after snapping. The phone generally hangs sometimes. I've done factory reset several times, but the problem still persists. A friend told me that the only solution is to flash stock rom
Reply
#4
(08-30-2015, 01:59 PM)Shateemah Wrote: The phone has been misbehaving, the screen auto rotate is not responding, camera snaps pictures upside down. I have to rotate pictures 180 degrees after snapping. The phone generally hangs sometimes. I've done factory reset several times, but the problem still persists. A friend told me that the only solution is to flash stock rom

granted! download @ https://forum.hovatek.com/thread-311.html and flash using Sp flash tool @ https://forum.hovatek.com/thread-159.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
(08-30-2015, 05:09 PM)hovatek Wrote:
(08-30-2015, 01:59 PM)Shateemah Wrote: The phone has been misbehaving, the screen auto rotate is not responding, camera snaps pictures upside down. I have to rotate pictures 180 degrees after snapping. The phone generally hangs sometimes. I've done factory reset several times, but the problem still persists. A friend told me that the only solution is to flash stock rom

granted! download @ https://forum.hovatek.com/thread-311.html and flash using Sp flash tool @ https://forum.hovatek.com/thread-159.html

thanks

Reply










Users browsing this thread:
1 Guest(s)